Showing results for 
Search instead for 
Did you mean: 

Odd MMS issue

Good Citizen / Bon Citoyen

Hi folks, 


I have a weird problem I’m wondering if someone can help me with. Just a couple days ago I started being unable to receive MMS from some people. Anytime I get a picture sent to me from certain contacts I get an “unable to download MMS” error. It knows there is an MMS message but cannot get it. But it only happens for some of my contacts, as there are some people I can get MMS from just fine and with no errors, and others that simply do not come through. 


This is a very recent development, and for the life of me I cannot figure out why. I haven’t made any changes to my settings, and I reviewed the MMS settings in the APN, and everything checks out there. I also don’t think it's the messaging app itself, since I tried using two different apps on my phone and had the same problem. I didn’t do a complete reset or anything drastic, but I’ve checked what I would consider the obvious problems (including making sure my data is on).There are two possibilities I can think of. 


This first one is pretty speculative, but could there be some sort of cross-network messaging issue? Here is why I am wondering about that. I can get MMS from some contacts who are also on Public Mobile, as well as Koodo, both of which are owned by Telus (and I assume use the same network). However, MMS messages do not come through from a contact on Fido (owned by Rogers), as well as my work phone which runs on Bell. I can still get regular SMS messages from other carriers. 


I also cannot rule out that there is something weird going on with my phone itself, but I don't know if you can even tell your phone to accept MMS from only some people and not others, and everything else is working fine. For what it's worth, I’m using a Motorola phone with Android 8.1. 


Has anyone ever experienced or heard of this issue? I tried searching the forum here since I’ve seen other people saying they were having MMS issues, but not quite like this (I’ll apologize in advance if I missed this one somewhere). Thanks for any help or advice you can provide.


Good Citizen / Bon Citoyen

@softech - The new MMS proxy and port settings I tried are and 8799, respectively.  Just to put this out there, I did go back to the original ones to try them out (proxy:, port:80) and now everything works just fine for those settings as well. Similar to @Srhughes, the problem just went away, for now at least.   No idea why the old settings all of a sudden work without issue now. But I'm hoping this particular issue has been put to bed. 

Good Citizen / Bon Citoyen

@softech just confirming that the trick with the Freedom Mobile SIM does work on an Umidigi A3 pro with Android 9 installed. I am using the settings I suggested to @stephenasmith and so far they seem to work. Running a few tests just to be sure.

@darlicious wrote:


PM will send a customer a configuration file for this issue.

I recall this being discussed before. Some (a few?) customers apparently received this file. Many (most?) customers (including me) who requested this file received nothing.


And I recall that some people reported the file didn't work for them.


That was a few years ago. Before PM became an obviously disinterested instrument of Telus.

Mayor / Maire

@stephenasmith   I'd agree with @softech .  If it's working for you now, don't bother changing anything... 😊

Mayor / Maire


PM will send a customer a configuration file for this issue.

@stephenasmith   just want to confirm, what do you have now for MMS Proxy and MMS port?


.. and if it works now, why change?  just leave it as is

Keep a note of what you have , in case it breaks again

Good Citizen / Bon Citoyen

Just a quick follow up from me. I've been using the alternate settings for MMS proxy and port that @Srhughes suggested for about a week and change, and everything has been working fine for me. 


I'm tempted to go back to the default settings just to see if they are working again for me  as well, given what @Srhughes reported in terms of it just fixing itself, but things seem to be good now. 

@Korth wrote:

. I think Umidigi isn't likely to suddenly enable this feature after they've deliberately locked it out - it's not a bug, not an oversight, it's an intentional decision.


I think it could be a fact that major market for Umidigi is some other countries, not North America,  and the carriers there are pushing the APN setting over the network

@Srhughes   (edit: wrong username)    Good to hear the issue has been resolved for you at least after all this time, but yeah too bad you're out a few dollars for the FM SIM.  Perhaps, it'll come in handy should FM (Quebecor) offer some great deals going forward?  😁

Good Citizen / Bon Citoyen

No, specifically the

Good Citizen / Bon Citoyen

Hi Korth,


As I mentioned, I got this info from the PM support team. The only changes they suggested were to the MMSC and the MMS proxy. If I could edit my APN settings, I could tell you what happens 🤣


The good news is it seems that stuff has sorted itself as of late. My group texts seem to be back in order but no clue why. It was multiple weeks of this issue and now it has disappeared.  Perhaps it was Murphy's Law; I had just ordered a Freedom Mobile SIM. 🙄

@Srhughes wrote:

Hi Stephen, yes the technician said all the other settings were the same. The old proxy and MMSC were deemed obsolete by the technician I spoke to.


It stinks because my phone won't even allow me to add new APNs let alone edit them. Still waiting on Umidigi tech support to get back to me. I suspect I will be buying a Freedom Mobile SIM soon... No outlets in Quebec but I can probably get one shipped.



MMS Proxy =

MMS Proxy Port = 80

MCC = 302

MNC = 220

APN Type = default,mms


Works fine for me. And for all my referrals. If Public Mobile (Telus) actually changed anything then they haven't made these years-old settings "obsolete".


As for Umidigi support ... lol.

UI-locked ("greyed out") APNs have been an issue on many (mainly low-end) devices for years. Since Android 8, perhaps even earlier.

There are a few workarounds - swapping SIM cards, editing existing APN profiles, root hacks to (re)enable the "Add New APN" option, etc. Some of these approaches work on some devices, some don't - you'll find these have all been discussed many times in this community. Some devices are aggressively "updated" by the manufacturers to keep this option locked out, to keep all these hacks and workarounds nonfunctional almost as quickly as they become public knowledge.


The simple fact is that your device model is designed to only accept pushed APNs. I think Umidigi isn't likely to suddenly enable this feature after they've deliberately locked it out - it's not a bug, not an oversight, it's an intentional decision.

The simple fact is that Public Mobile doesn't push (broadcast) their APN settings onto the network. I think it's unlikely they'll suddenly provide this push service after persistently refusing to acknowledge many customer complaints about it for years.

@Srhughes  some great info you provided...


The old proxy and MMSC were deemed obsolete by the technician I spoke to.

which one was the old one?  the

Mayor / Maire

@stephenasmith  @Srhughes 

I seemed to have missed this whole saga? Off the top I thought I would mention s couple if things...Oreo 8.1 does cause an issue with greyed out APN settings blocking the ability to edit them. Common on phones such as Umidigi I haven't heard if it affecting Motorola phones. There are 3 usually successful ways to fix this issue...


  1. Update your OS to Android 9. Reboot your device.
  2. Use a freedom sim card to update your APN.
  3. Contact customer support to text you a configuration file.

However the "MMS" issue appears to be more an inability to edit your APN issue although if you are able to update to Android 9 it may be advisable to do so. With a little research I came across a troubleshooting page for this issue. The tips seem to be in an odd order and you have tried several of them already. A couple I had never heard of and the very last suggestion is the lost/stolen trick?!! Which is the most "powerful" provisioning tool a customer can use before turning to customer support to reprovision a sim card from the back end. Since its likely a device issue its probably best to leave it last given the glitch it causes with rewards not applying upon renewal. Here's a summary of possible solutions....


  1. Change network mode. (Switching to the 3G network did help but is only a temporary fix.)
  2. Enable/Disable auto retrieve MMS setting.
  3. Disable the Package Disabler. (Huh? I've never heard of this?)
  4. Enable Download Booster. (Another new one have never heard of?)
  5. Clear cache and data for MMS service/app. (Back up data first!)
  6. Clear the cache partition.
  7. Disable IPV6 protocol.
  8. Change messaging apps.
  9. Reinstall/Edit/Update carrier profile/APN.
  10. Update Profile and PRL.
  11. **Use lost/stolen trick. (Log in. Suspend via lost/stolen. Log out/in. Resume via lost/stolen. Log out. Reboot.....then contact customer support after renewal to have $$ rewards applied manually to your account balance.)

Detailed steps for each troubleshooting tip can be found here....

Good Citizen / Bon Citoyen

@Srhughes - Thanks for the confirmation. 


Yeah that stinks. I can't edit the default APN either, but I was at least able to create a new one with all the same settings as the original, except for the new proxy and port. Need to do some more testing, but at first glance it seems to have fixed the issue. 


Will report back after I've had some time to determine if this fix holds up or if there are still issues lurking somewhere else. 

Good Citizen / Bon Citoyen

Hi Stephen, yes the technician said all the other settings were the same. The old proxy and MMSC were deemed obsolete by the technician I spoke to.


It stinks because my phone won't even allow me to add new APNs let alone edit them. Still waiting on Umidigi tech support to get back to me. I suspect I will be buying a Freedom Mobile SIM soon... No outlets in Quebec but I can probably get one shipped.


Good Citizen / Bon Citoyen

@hTideGnow- I have a Moto G5 plus. APN info is:



But from what I’ve been told by customer service these settings are correct. 


@esjliv- Yes I was in contact with CSA, and shared my APN information with them during my correspondence with them. They said everything checked out fine. We went back and forth quite a bit but I got the sense they were stumped by the end of it, 


@Srhughes- Thanks for the suggestion. I am going to try out the first one, try to create a new APN (and keep the old one just in case) to see if that works. Were all the other settings the same? Also agree it's frustrating that this just started. Will see how this new solution turns out. 

Good Citizen / Bon Citoyen

Stephen, I have news... Some good and some bad:


  • The issue is indeed with the APN settings. As was suggested earlier here (I think), the mmsc proxy should be: and the mmsc port should be 8799. This was confirmed by a PM tech support rep. This would explain why your switching between works temporarily. The MMS proxy and MMSC are inputted correctly in the Telus APN but not the default Public Mobile one.
  • One fix suggested by the tech support agent was the following. It did not work for me but it has worked for others: go to and try adding APN using "shortcut master (Lite)
  • Else the suggestion Softech posted earlier about swapping out the sim card might be the way to go. Here is a how to:

I am going to try talking with Umidigi support before buying the new SIM card. 

Good Citizen / Bon Citoyen

I can't seem to add new APN... I had thought of adding a new one manually. Will try again today. The OS is up to date.


I may try your Freedom SIM idea. The thing that still bothers me is how this happened after 2 years and out of the blue. 


My ticket is being run up to the tech support team. Will share any news I have.

Good Citizen / Bon Citoyen

We are two different people



What is your MMS Proxy?  It didn't show.  It should be:

MMS Proxy:


For MMS Port, instead of 80, try :
MMS Port: 8799


For APN Type:, try 

APN Type: default,supl,mms,agps,supl,fota,hipri


I understand you cannot update your APN.  Can you add new?


 Umidigi is one of the worst one in terms of editing APN, very trouble.   Two things you can do to make the edit (and/or add new) features to come back

1. Make sure your OS is up-to-date

2. Find a Freedom sim card from friends,  put it in and the APN Add New should be there.  Manually add All APN settings back.



Let us know how it turns out

Mayor / Maire

@Srhughes @stephenasmith - are you one in the same? Or, different?


@stephenasmith - this has been going on for some time now..July 23rd and no resolution?

Since your original post other members have posted over the past 2 weeks about MMS and messages circling or not receiving/sending.

Now, not sure if all is the same issue, of course, as there there be different things that could perhap fix it. 

Have you reached out to CSA at all during this time? Wondering what they have to say, if there is a known issue or not?

Good Citizen / Bon Citoyen

On a related note, the problem started happening for me when I was in a remote area... I thought that was it! But when I got back home, the problems kept up. I will try switching to 3G and see what happens.

Good Citizen / Bon Citoyen

My APN settings are also greyed out but they are the correct parameters. I am using an Umidigi A3 pro running Android 9:




 I also started a ticket with PM and sent Feedback to Google re: Messages app. I will update the community if anything useful comes of it.





HI @stephenasmith   Yes, APN could be the issue.


what kind of phone do you have?  and make and model?


can you share your current APN settings? maybe screenshot?

Good Citizen / Bon Citoyen

A factory reset is bit currently in the plan for me at least .


Actually I just found something that might be helpful. I can't change the APN settings on my phone, they are greyed out and cannot be edited, but I can change the network preference. The default on my phone is LTE, and I don't seem to be able to get MMS when on that, but strangely when I downgrade to 3G then I can get the MMS messages. 


(I noticed last week when I was in poor cell reception areas and I didn't always have LTE service that I magically started getting MMS again from problem contacts, ironically enough. But when I got back to "good" reception the problem came back. Just occurred to me now though.)


No idea why this would make a difference, and it needs some more testing, but throwing it out there in case it helps anyone. 

Hi @stephenasmith you shouldnt  need to Factory Reset, ot probably overkill

Good Citizen / Bon Citoyen

I never did a factory reset. I thought someone else had tried that, but without success.

Good Citizen / Bon Citoyen

Unfortunately the network reset did not work. Thanks for suggesting the idea 

Great Neighbour / Super Voisin

Resetting my network settings fixed it for me. Settings > System > Reset Options > Reset wifi, mobile & Bluetooth 

Need Help? Let's chat.