Showing results for 
Search instead for 
Did you mean: 

Esim never registed and can't access account

Good Citizen / Bon Citoyen

I paid for my subscription and downloaded the app. I left the app to respond yes to the koodo text message asking to port my number and when I returned to the app it just kept waiting for my phone to prompt me to set up my esim and never did. After 20min I closed the app, like an idiot, and now I can't even access my account anymore because it wants to send a code to my phone number which I don't have access to. I think I need a QR code sent to set up my esim but I can't even open a ticket because I can't log in. 

Any advice would be greatly appreciated!


Good Citizen / Bon Citoyen

Thanks everyone who helped out! I'll make a summery here to help others who run into the same problem.

The start:

I signed up and paid for a PM subscription and entered the info to port my number from koodo. I had a koodo SIM but chose to use my eSIM for PM.

Everything went smooth until I downloaded the PM app to finish setting up my account/ eSIM.

The problem:

When you open the PM app for the first time it goes through a few steps, the most important of which is one that says something like "your phone will prompt you to set up your eSIM, this will take up to 2 minutes, please do not close the app".

During this step I received a text message from koodo asking me to reply "Yes" to port my number to public mobile.


I switched to my text message app for a minute to reply yes to that message, and very soon after my koodo SIM became unregistered so I lost my service from koodo. 

When I returned to the PM app it was still on the step waiting for my phone to prompt me to set up my eSIM. It stayed on this step for 15+ minutes and never prompted me so, not knowing what to do I closed the app hoping it would restart the process when I opened it again.

When I reopened the app it acted as if the set up as successful and assumed I had my eSIM set up properly and could receive text messages.

From that point on I could not log into my public mobile account without inputting a code sent to my phone number, which I did not have access to through koodo or public mobile.

The solution:

I was still able to log into the community site by verifying with my email so I posted here and got some helpful advice:

1. I was able to submit a support ticket after grappling with the chat bit for a while, but I don't believe this is what ultimately lead to the solution.

2. I was able to get in contact with koodo's port team who confirmed my number had been moved to PM, which was bad news for being able to access it but at least let me know where it was.

3. I tried resetting my network settings and entering incorrect codes to try to get an alternate way into my account but both lead nowhere.

4. I messaged a CS agent (you can find the link in this thread) this was around 8-9pm and I did get a reply that night asking me to verify some security information but by the time I replied back with that info it was 9:30-10 and I did not receive any more messages that night.

5. I replied again to the message from the previous night at 9am and by about 9:30-9:45 a different agent messaged me with a QR code that I used to set up my eSIM.


My advice:

Don't leave the PM app for anything during the set up except to actually set up your eSIM.

Don't finish porting your number until your eSIM is set up properly or buy a sim card to avoid this situation. 

Thanks again to everyone in this thread and the CS agents who helped me out as I was panicking!

HI @BenVO not bad the time.  

Since support closed at 10pm, that' why you don't get a reply until  9:xx am

Good Citizen / Bon Citoyen

Hi, I submitted a ticket around ~9pm and messaged a PM agent around the same time, got a message from a PM agent shortly after to verify some account information, which I did, but didn't get another reply that night. I messaged again at 9am and had a qr code sent to me by about 9:30-9:45am.

Good Citizen / Bon Citoyen

How long did it take for you to get an answer? I'm currently without a phone because of this and I have been since last night. I know it's probably my error but I need to things up and running!

HI @BenVO   yes, it is just the account and eSIM setup.  PM agent might not reply you tonight.  Please submit another ticket tomorrow morning, or message them for update

Good Citizen / Bon Citoyen

Managed to get into contact with koodo and confirmed my number did port but they couldn't help me with the esim. Just have to hope that PM responds to my ticket and generates and new esim for me.

Great Neighbour / Super Voisin

This happened to me today, too.  I need the QR code, but didn’t receive it during the registration process.  I went through the loop you describe several times.  It was a lot of trial and error to get into this forum.  Handy1 was extremely helpful and sent me a link to a Customer Service agent.   I had to verify my account - but just received my QR code 10 minutes ago and I am connected.  I can see Handy1 sent you a link.  You will get there!


Good Citizen / Bon Citoyen

I managed to submit a ticket, I guess I must still be signed in somehow. Not sure what's going on at this point honestly. Hopefully get a response soon. Thanks!

Good Citizen / Bon Citoyen

I messaged the CS agent, I can't submit a ticket as far as I can tell because I can't access my actual account because it wants to send me a sign in code via sms.

Mayor / Maire

HI @BenVO   have you submit a support ticket yet?

ESIM activation has been having issue last couple days.  so, submit a ticket and they can check if it is any problem with your activation.  

Please let us know the progress and we can update others . thanks



you can try this to see if you can log back in the app and continue with the workarounds below, or message support for help

  1. Reset your password to self service account. Once reset, sign in again with new password. Might be able to receive 2FA via email instead to gain access.
  2. Potential workaround (for some): If you don't have access to SMS OTP, try entering an incorrect OTP code 4 times. For some individuals, this is giving the option of an email instead.

If none of those workarounds helps,  please open ticket with support and have them to help in this situation:

Private message CS agent at 
**Monitor your Community inbox (envelope icon on the top right)


Mayor / Maire

@BenVO  First try rebooting the device , and reset Newark settings ,, if still not working contact support to reset your account 

  • while your already here and logged in the community


  • you can send a private message   To CS_Agents by clicking >>>>>>>>here.


Need Help? Let's chat.