Showing results for 
Search instead for 
Did you mean: 

Voucher top up doesn't work - website doesn't update my payment.

Great Neighbour / Super Voisin

My account is suspended, but it says on the website I can top up and reactivate my account. I put a $10 voucher yesterday, which is registered on My Public mobile profile, but when I try to top up another $10 voucher to reach my plan, it tells me top up successful, but it doesn't register it as paid. Thus, my account is still suspended. I keep trying and it keeps saying successful top up, but I got no service at all. I tried calling a friend and one call went through, but no text or data available. 


Mayor / Maire


Call 611 from your phone. Does it tell you your service is active? What is your balance according to 611? What is your plan? It's always best to add vouchers via 611 as it will automatically reactivate any suspended account for non payment.


For future reference if needed.....

Mayor / Maire

@gasaba_87  - you said you were able to make 1 call go through? Then you have services and your account should be Active. It is likely the suspended message is an old cache version of your screen; follow suggestions provided to see updated info.


Now, as for no text or data, that doesn't make sense. If restarting your phone doesn't help (as suggested by @hairbag1 ) try 1 or more of the below:


  • toggle into and out of airplane mode
  • perform a Reset of the device's Network Settings
  • move your sim card to another phone to see if services works
  • manually select the 3G / WCDMA ONLY network in your Mobile Connections area in your settings (temporarily) to see if services work


If you think some of the vouchers are still not added to your account, you can also try adding them by calling 611 from your device. Although, if you tried the same number multiple times already, I'd wait an hour or so before trying to add them again.

Mayor / Maire

Some vouchers have 24 hold period before they can be used.

Try using different browser. Try Incognito/private mode. Clear browser’s cache. Try forced refresh. Use computer and not phone to log in.

Mayor / Maire


try shutting phone OFF...then restarting.


@gasaba_87   The site has some serious caching issue.  Please try to login to again using incognito mode and see if you see the correct Available Fund or correct account status there


Check the Payment history and see if it makes sense


If not, provide us more info and send us screenshot from Payment history page

Need Help? Let's chat.