Showing results for 
Search instead for 
Did you mean: 

Troubles connecting to 5G network

Good Citizen / Bon Citoyen

This may be a question for a CS rep but thought I would start here and go from there.  Current phone is OnePlus 8T.  According to specs this phone does have 5G compatibility.  I have been using this device around 2 years with PM on a grand-fathered plan with no issues.  Decided to switch plans to a 5G plan as the old plan no longer fit my needs anymore.

Chose my plan and the option to switch on renewal date.  This is the first day on the new plan.  This morning the phone wouldn't connect to the network.  After a reboot everything is connecting.  However I am not able to connect to the 5G network.  All I see on screen is 4G or 4G+.

On my phone the Preferred Network Option only has 4G/3G/2G (Auto), 3G/2G (Auto) or 2G Only as options.  The settings for Preferred Network Type appear under the sim card settings on this device.  I have been on PM for the last 4 years with the same plan and same sim card - is it possible that the sim card is not compatible with 5G and would need a new card?

Device is fully updated, restart has been done, APN settings have been checked.  All seem to be good.  Possibly this model is not supported under 5G.

When I check the compatibilty page all frequencies are listed in MHz while the 5G bands listed in the spec information are nXX.  I am not network savvy so not sure if the 5G bands listed for this deviceare compatibile or not with the PM 5G network.


The last speed test I ran just now is at 83.69 Mbps download.

Any thoughts or suggestions on things to try?  I know I have gone down a rabbit hole of moving away from my grand-fathered plan and really don't want to switch plans again but not sure of a way to move forward.

Forgot to mention I am in Edmonton so connecting to 5G shouldn't be an issue.

Thanks for any assistance you can offer.


Good Citizen / Bon Citoyen

Nope, it's a Public Mobile SIM! I just didn't want to wait for one to be mailed out so I went and got one in person.  The Telus/Koodo stores still carry them.

HI@Goaway you said Telus store, but it is a PM sim card? or you meant you tested with a Telus sim?


Good Citizen / Bon Citoyen

I've got an 8T in Edmonton as well and had all kinds of weird connectivity issues after the 5G rollout, it just seemed flakey.  So did my other ancient Mi5X with an old SIM card. . After trying all the flavours of OxygenOS 11-13 and a few custom roms, different firmwares and modems I did get a 5G connection on the 8T, but it seemed to make it even more unstable.  I'm not sure if it was the custom ROM or one of the firmware updates that gave me the option. 

I finally switched the SIM card out for a brand new one, the Telus store rep said they got them after the 5G network changes and it has been completely stable for about 2 days now, even connecting to the 5G network. I'm on a 4G plan but it says it's on the 5G network and I get the throttled ~100Mbps down and ~10Mbps up.  IMS provisioning says it's not registered but at least it has a stable connection now.

I'm not sure if it had something to do with the SIM cards I was using being several years old and the 5G network changes, if I somehow managed to damage multiple cards in multiple phones around the same time, or if it was something in the back end that updated when I entered the new SIM number, but a brand new SIM seems to have been the solution.

Mayor / Maire

@sheytoon- Why else? To sell more new product. Oh sorry your phone won't work for our latest services. But this one over here does and we have a special price just for you. Yeah whatever so your phone can actually use those services but we're not gonna let ya. Buy more. Spend more. No we're no longer more for less. Just empty every pocket. Dang corporations.

Mayor / Maire

Yeah I'm starting to thing there's shenaningans going on too!

@softech it's definitely the phone software causing it, but now I'm thinking it's possible PM/Telus asks them to enable or disable features like VoLTE.

I really don't know why they would request disabling VoLTE at this time. It makes no sense.

But then again it also makes no sense why Samsung or Google would disable it, so I'm at a loss 😂

Mayor / Maire

Great stuff as always @sheytoon . Public techs were telling me that a phone might indeed get enabled but then some other crawler from Telus will come along and revoke it if it doesn't approve of the device. Sucks.

From another user here I did get some APN settings and tried to put them in but no go. I do not have the line saying provisioned in that screen. Although the same tech claimed that he turned it on so I could see if it suddenly magically worked and no go again. Perhaps I should have taken the time and looked for that provisioned and tried the apn's but he was on the phone while I was looking and so I didn't want to take all his time.

Another device I have did not show 5G even though it was a 5G phone. Then there was an OS update which then caused 5G to appear and lo and behold volte too. So I'm sure there has to be some shenanigans between the providers and the manufacturers. More suckage. Too darn much cahoots going on with these sneaky corporations.

@sheytoon you think it is the phone manufacturer and not carrier??

@softech FWIW, I also had VoLTE on Pixel 5a for a few weeks and it stopped working as well. No idea why Google disabled it.

Great Neighbour / Super Voisin

Thank you @Just_a_guy Based on your inputs, I was able to resolve the issue on my phone as well.

I did it using *#*#4636#*#* > Phone Information > Network Type (you'll need to install the Google Dialer app and set it as default for this to work on a OnePlus device, don't press the call button after typing it).

Just a tip - if you prefer using an app, you could use Net Monster as it does not have annoying ads like 5G Switch. Only caveat is that it sends annoying notifications and 'requires' the notification permission but you can disable these notifications from the app's own settings. 

@softech sorry I meant the "VoLTE Provisioned" toggle in*#*#4636#*#* menu, as well as the "IMS Service Status" sub-menu.

Unfortunately you cannot manually trigger IMS registration. If the phone's software allows that procedure for PM SIM cards, it'll happen automatically. Otherwise no hope until a software update enables it. There's not much PM can do, other than pressure phone manufacturers.

I had thought manually creating an ims APN might trigger IMS registration, but it seems that's not the case.

@sheytoon which "the toggles in the Android menu." you are referring to? 

and how can I manually trigger an IMS registration rather than wait for PM's invite? My phone, S21, is capable VoLTE and did register for couple days until it got deregister and never able to get back on VoLTE since

Mayor / Maire

@dust2dust @softech hey guys, I think I figured out the meaning of the toggles in the Android menu.

"VoLTE Provisioned" means the SIM has an ISIM module with IMPI and IMPU identifiers. Basically what this means is that your account is provisioned, and the phone (via SIM) has all the info it needs to perform IMS registration.

Any VoLTE-capable phone should then start the IMS registration procedure with the IMS core network. This does require the phone to have ims APN configured, but this is usually hidden in phone menus and users won't see it.

The overall procedure is like this:

  1. Phone sends PDN Connectivity Request with "ims" APN to 4G EPC core network
  2. Network sends Activate Default EPS Bearer Request for QCI 5
  3. Phone accepts the request and sets up a QCI 5 bearer to allow IMS signaling
  4. Phone starts IMS SIP registration procedure (using the newly set up QCI 5 bearer), which includes authenticating with the IMS core


If registration is accepted by IMS core, the "IMS Service Status" menu in Android will show "IMS Registration: Registered".

Once you're registered on the IMS network, you will be allowed to use certain services as allowed by your plan's subscription. Services include VoLTE, ViLTE, VoWifi, RCS.

@Just_a_guy- Thanks for the update. I was looking for evidence of volte. Not likely but worth looking for. On my Samsung, the place to find the evidence is settings, about phone, status information, sim car status - here you might see some mention of IMS. If so then does it say registered. Or say you call 611 and just let it prattle on and come to this screen and look at mobile voice network type - does it say UMTS? When not on a call it would likely say LTE.

Good Citizen / Bon Citoyen

@softech- yeah I am able to access 5G.  Had to do some messing around to get to it as it appears the options to select 5G appear to have been disabled by the phone manufacturer.  Kind of silly that I have to get to the options the way I did given this model has the hardware for 5G.

@Just_a_guy so, you can use 5G in the end?

35 to 50 is decent, not great, but you are in the basement

over 100Mbps is good, enough for most browsing, video streaming needs

Good Citizen / Bon Citoyen

@softech- i work in the basement of my house.  On 5G right now I am getting between 35 and 50 Mbps.  When I am outside that jumps to well over 100 Mbps.  Maybe not quite the 5G speeds that Public is quoting but not too bad either - considering I came off a 3G plan.

@Just_a_guy   what exact speed you got from speed test?


Good Citizen / Bon Citoyen

@dust2dust- i did try the *#*#4636#*#* code but that doesn't seem to do anything.  Every time I try I just see my contacts list but no other screen comes up or does anything else.  So this could be another function that has been disabled by the manufacturer.  I haven't noticed UMTS or anything on the screen when on a call.  But can keep an eye out for it.  Don't use the phone for voice often but I can have some of my meetings call me and can observe.

For information this was the thread that I tried to follow.  I did take me through steps that I was not familiar with and some just didn't seem to work.  I think the main thing for this model reading the background is that there is carrier information settings that likely need to be updated.  But as mentioned I couldn't get there when trying to follow through.  So the 5G switch app was the next option. .  The code you mention is listed in these steps.

@softech- I ordered the 8T directly from OnePlus' Canadian site.  Somewhere on the OnePlus Community forums I came across a listing of the model numbers and which version of the OS that model has installed.  Canada does not have it's own version.  My model is kb_2005 (I think) and per that list this model has the global OS installed on it.  Speeds seem to be somewhat limited on 5G when I am in the house but step outside and they kick up significantly.  A little annoying that this functionality is not enabled by default but am happy that I can access it.


@Just_a_guy did you get the 8T in Canada?

even without 5G, when you choose 4G, you can get much faster speed than the capped 4G plan speed, 100Mbps.  So, run a speed test and see how fast you are getting.  If you are getting way over 100Mbps, I would say it's ok without 5G

Mayor / Maire

Great report. We've seen a few instances of the volte toggle but not working. You can forget about wi-fi calling (vowifi) for an as yet unknown time.

Can your phone do the *#*#4636#*#* code? Or if you dig down into the sim card status and make or take a call does the voice line say UMTS? It likely says LTE now but it could change when you are on a call. Or even in that screen if you see mention of IMS and if it says registered then that would be good too.

Good Citizen / Bon Citoyen

Thanks all.  Have been somewhat busy and not able to post an update earlier.

I did work with a CSR rep and tried a number of things.  SIM swap with a known 5G phone (other than mine) and yes showed the 5G one his phone.  Didn't try with his SIM card as he is not on a 5G plan and he is also with another Telus carrier.  Rep confirmed there was nothing in any settings and that the specs would work on Public and other Telus carriers.

I started to do some research and found that other owners of this model globally have had this issue.  From what I can gather this issue has been present for a couple of years.  It appears that the manufacturer actually disabled the ability to choose 5G options in the global OS.  The functionality is there but not available to owners of the global version of the phone.  In some of the threads I found on the issue some people indicate ways to enable these settings.  I tried following some of the suggestions (like going through developer mode and updating certain settings) but was not able to access some functions that I should have been able to.  Not sure if these are disabled by the carrier or the phone manufacturer.  In any case this still wasn't working for me.

Another suggestion on these forums was to download an app called '5G switch' or something like that.  This app can get access to these settings even though the manufacturer has disabled access to them.  A little playing around and I got it to work!  I do now have the 5G showing on my phone with my Public Mobile SIM card.  It is not the ideal way of fixing this issue but it is a work around.  If I install updates or restart the phone I have to go back in and re-enable the settings.

@DM100- I will have to find someone with a 5G plan on a different carrier and test to see if I have the option to select 5G appears.  That is a good suggestion and something I will try at some point.

@dust2dust- That is something that is very curious.  I think I have found through all this that manufacturer has disabled this functionality for some reason.  The phone does have the 5G capability and it works on Public Mobile after messing around to get there.  Not sure why the manufacturer would disable the access to these settings but that is where I am at at this point.  My phone also has VoLTE enabled but Telus will not enable that to work with their networks for some reason.  So no VoLTE for me at this point.

So below in the screen captures you can see that 5G is showing on the phone.  But the 5G/4G/3G/2G (Auto) option does not appear in the menu under preferred network type.  However in the other shot it shows that that is the setting that is currently set for Preferred network type.


@DM100- It gives me more thinking that Telus is doing non-standard network finagling. It's like with volte. My phone can do volte. But Telus won't let it. Your phone can do 5G but they don't detect its capability. Something fishy is going on with Telus. And it stinks.

Great Neighbour / Super Voisin

@Just_a_guy Did you manage to solve the issue?

I have the same problem with my Motorola Edge 30. In network options, my Public Mobile SIM card only shows 3G or LTE, but when I insert a friend's Rogers SIM card, it does show options from 2G, all the way up to 5G. Based on my research, the phone should be compatible with the Public Mobile network.

Not sure what's going on. 

Screenshot with Rogers:


Screenshot with Public Mobile:


Appreciate any help. 

Good Citizen / Bon Citoyen

Thanks all for the replies thus far.

So far the issue still hasn't resolved.  I will try the sim card swap suggested - both taking my sim card and putting it into a known working 5G device and dropping another working 5G sim card into my phone and see if the issue persists.

I will reach out to a CS Rep and see what kind of a response I get back.


@Just_a_guy but you are not alone

 Maybe it is because the phone is not 5G compatible with PM??

Mayor / Maire

Something is not right. Preferred network option should always have a 5G option, regardless of your SIM or plan.

If you put another SIM in your phone, does the 5G option appear?

Good Citizen / Bon Citoyen

@pmbc - True maybe I am just being a little impatient!

Deputy Mayor / Adjoint au Maire

@Just_a_guy You might want to give it a bit of time.  There was another post yesterday from someone with a Samsung S21 Ultra I think and they were getting LTE+ with about 200Mbps down on speedtest.  They had just migrated to a 5G plan and later in the day they reported the phone showed 5G.

edit: added link to other post.

5g not working and I have 5g coverage and 5g phone - Community (

Since you just migrated to the plan give it a day and see if the connection indicator changes.

Great Citizen / Super Citoyen

Even on a non 5G plan a 5G connection should show on compatible devices. It's possible your device doesn't support 5G on Telus.

Edit: I believe it should work after a quick search. Not sure what's wrong there.

Need Help? Let's chat.