Showing results for 
Search instead for 
Did you mean: 

Plan not displaying correctly in my account

Great Neighbour / Super Voisin

Back in November I signed up for the 20GB at 4G speed Black Friday promo.


When I look at my payment history it is showing I was charged for this plan in both December and January. However, on my Account and Plan pages it is still showing I am on the 4.5GB at 3G speed plan and that I only have 4.5GB available.


I have tried submitting tickets multiple times but am never able to submit them as the submit button won't work for me. I am very frustrated. Anyone else having this issue or have a recommended solution?



good news !!

Good Citizen / Bon Citoyen

@hairbag1 thanks.

Using incognito mode worked and everything was updates/displayed correctly. Appreciate the suggestion.


try logging in on your laptop, but this time use incognito mode.

Also, clear your cache files and also try a different web browser. 

I suggest Firefox, if you haven't already tried it.

@Kartye  I suggest having support look into that then your pricing seems off should just be $40 for 30day cycle 

Good Citizen / Bon Citoyen

I have a similar issue.

I have used the refresh button and it did update the data usage, but not the payment information. Here is my data usage. Notice the plan says it is from Nov to Feb, or 3 months. But the data usage is correct for my current plan. I used to be on the 12Gb, 90 day plan, but switched to the 15Gb 30 day plan for $40.



When I see my upcoming bill, it is for a 3 month payment, from my old plan.


When I look at payment history, you can see the last payment was for a 30 day plan and was paid in January. So the date from the plan usage of Nov - Feb does not align with the fact I am not on a 30 day plan, and have made a payment in January.



Mayor / Maire



Logging in issues is common with Public Mobile’s website, which displays outdated information, to deal with this:


  • Try clearing cache and cookies and opening an incognito tab
  • Try using a completely different browser from a completely different device which does not have stored/remembered credentials
  • If you're using a device with stored/remembered credentials on Chrome browser, sometimes when these autofill, the device also attempts to automatically log you in.  If your device does this, do not tap the sign in button while it is trying to log you in as it will deliver an error message every time and appear to not let you login.


Also, try tapping the highlighted area when logged into self-serve for a refreshed page version:





Great Neighbour / Super Voisin

Thanks to both of you for the quick replies. I had tried logging out and back in multiple times, but never noticed that little refresh icon. That did the trick!

Mayor / Maire


Try again  incognito mode/private mode or simply try refreshing the page on the yellow circle while signed in to public mobile

Updating Media


Refresh page.                                ^^^            


Need Help? Let's chat.