Showing results for 
Search instead for 
Did you mean: 

PM App (Android) stuck on my account

Model Citizen / Citoyen Modèle

Was trying to buy a US roaming package for a relative (P2) (was later successful on the website). Opened the PM app (v1.4.1) and it wouldn't get off my account. I tried several times to login with the relative's info, including doing More > Log Out first, which took me to the main Login/Shop page. Each time I tried to login as them, it sent them a text with 6-digit code that I entered.

Then when in, it still shows ME under My Account, not them. It comes up with my account info under My Account (referral code, billing cycle, usage, etc.) after logging in as them. If I type the Add-Ons link, it takes me to a page to buy Add-Ons and appears it will let me, and it's my registered credit card.

I gave up on the app and used a browser to login as them and buy the Roaming Package. Appears to have been successful, we see it in their account but they didn't get texted confirmation of purchase. I haven't tried to login as me on the app since that happened, nor have I logged out as them. Now when I launch the app (after killing it from recent apps), My Account tab still shows my account including the opportunity to buy Add-Ons as me. My Rewards shows them (Billing Cycle, Rewards, Estimated Costs, Referral Code).

I have a couple of concerns, and I'm wondering if others are seeing this before I contact an agent.

(1) launching the app shouldn't allow purchases without prompting for login, even if you didn't logout before (I accept it might be a decision by PM to trade some info for convenience, like when billing cycle ends or current cycle's usage).

(2) when I logged in as my relative, the app changed the info on My Rewards tab but not the My Account tab. Beyond the obvious privacy issues, if I were not paying attention I could easily have bought a Roaming Package for my account, even though I had just logged in as them. Or they could, if I had just logged out and handed them my phone to make the purchase themselves. There was no prompt to confirm info during purchase, just "use registered card, these are last 4 digits".

Is anyone else seeing this?



Mayor / Maire

I've experienced this as well. There are caching issues with the app. Best to just use the web, but if you do want to use the app to manage multiple accounts you need to go into your device app settings and force shut down the PM app and clear the cache for it (after logging out).

Model Citizen / Citoyen Modèle

[Spoiler: first review from Nov 19 of app on Google Play Store describes exactly the same thing. PM responds that they're working on it. Current version issued Nov 4.]

Logged out. Deleted cache and data. Power cycled phone (not just restart).

On restart, launched PM app and was prompted to login. Got a different relative (P3) to login on my phone. Their My Account and My Rewards came up correctly. Logged out.

Logged in as me (P1). Different result this time, both My Account and My Rewards still showed P3. Before my first post, My Account was stuck on P1 and My Rewards had correctly changed to P2. So now worse.


Mayor / Maire

That does sound concerning indeed. I find that it's  hit and miss clearing cache. I log out and log back in and sometimes to no avail. Even power off phone and log back in. Waiting for about 30 minutes.  When all else fail, un install and reinstall.  Again, not always successful. 

Pain 😒

Mayor / Maire

HI @ottawa 

cache issue is a big thing with PM app and web My Account

clear cache or even clear data first and try 

still fail, then uninstall and reinstall the app

or try using Incognit/private/secret mode on your browser to test

Need Help? Let's chat.