Showing results for 
Search instead for 
Did you mean: 

Group texts not working

Great Neighbour / Super Voisin


I use a OnePlus 10 Pro and service has always been fine. About a week or so ago, my group texts and texts to any of my contacts that I'm also in a group text chat with stopped working. All I get is "Attachment" and loads of notifications that "A message from X failed to download".

I've tried deleting the groups from my phone. I've restarted. I've toggled airplane mode. I've tried with and without data turned on. Nothing works. I've tried to submit a support ticket but the page constantly 404s, even after clearing my cache and it won't load in an incognito tab.

Does anyone know how I can fix this? I basically can't text anyone so it's making my phone useless.



Great Neighbour / Super Voisin

It worked but are there any safety concerns with entering the data?

@Nique can you find the APN screen on your phone?? if so, delete the current A)N profile and add new one after (you need to type in all the info as my post above)

Great Neighbour / Super Voisin

Goto settings, mobile network, sim, access point names, touch the little i in the mobile internet box. Check and change your settings and hit done.

Great Neighbour / Super Voisin

Thank you for these instructions but where and how do you do this?  Not tech savvy, is this something I can do myself?   No risk of wrecking phone?  Thank you 

Great Neighbour / Super Voisin

Thank you. I ended up updating MMS proxy and port since I could not delete default. Creating and selecting a new APN profile keeping the default as is did not work for me.

Great Neighbour / Super Voisin

This worked for my OnePlus 10 pro updated to 14. I just edited the App instead of deleting it. Proxy and port were wrong.

HI @majikdragon 

yes, iPhone uses iMessage and Android uses RCS.  iPhone supposed to be able to send to RCS soon, not sure how sure.  

You can send MMS, but I find it confusing too.  So, personally, I like using Whatsapp more

Great Neighbour / Super Voisin

Hi Jim,

I thought it had worked for me, but actually hasn't. I've done some more research and it looks a little like an Apple issue - as they've not implemented RCS yet and all the people I'm in groups with use iPhones. I'm not really sure what to do now, other than wait for Apple to catch up.

Great Neighbour / Super Voisin

I added the new APN profile to my OnePlus 10 pro but still get a text error message " Can't get MMS:timeout".  I get the text part of the message but not the photos. Any suggestions?

Great Neighbour / Super Voisin

Likewise, I am having MMS problems with my OnePlus  10 Pro. Have you been able to fix your problem? Changing from the original default setting to those outlined nicely by Softech did not work for me.

Great Neighbour / Super Voisin

Hi,  I saw your question with regards to the group texts etc...   my Galaxy 6 did the same thing, along with suddenly being unable to send pics thru text. Both of these functions are of course MMS.  The short of it is..

Telus shut down some of their "legacy servers" which handle the MMS function. This affected "Leagcy users" ...translation is :  old phones aren't being supported by our old servers now for the MMS function. Apparently the servers are at the end of life and the vendors won't maintain them.  The Public Mobile website has posted instructions for a specific reset to the APN on your phone. I have not found it yet. A friend on Public Mobile also had the same problem with his older Galaxy phone this week.(2-20-24) The fix worked for him.  Good luck!




Great Neighbour / Super Voisin

Thank you! Yes, it seems that the OS14 update might have done it. Strange, as my husband has the same phone and did the update and his is fine. Just my luck. Thank you and everyone who answered.

Mayor / Maire

@majikdragon  Can you test the SIM card in another phone to try and see if it improves 



did you just update the OS to Android 14?

there has been some issue with OnePlus after the Android upgrade

A suggest is to first try Reset All networks

If that does not work, please go to the APN screen, delete the current APN profile. 

Then Add new profile and add according to this, please note case-sensivitve and do not add extra spaces

Username: <blank>
Password: <blank>
MMS Proxy:
MMS Port: 8799
MCC: 302
MNC: 220
Authentication Type: Not Set
APN Type: default,supl,mms
         or    default,mms,agps,supl,fota,hipri
           (might need to include DUN for hotspot, please note case sensitive)
APN protocol: IPv4
APN roaming protocol: IPv4
APN enable/disable: APN enabled
                or  Turn APN on/off APN turned on
Bearer: Unspecified
MVNO (Mobile virtual network operator) type: GID
MVNO (Mobile virtual network operator)value: 4D

Need Help? Let's chat.