Showing results for 
Search instead for 
Did you mean: 

Unable to login to public mobile account

Good Citizen / Bon Citoyen

I am unable to login my account on public mobile. Every time I login, it says you have active public service and confirm your full access by verifying mobile number. But I was never able to install esim while subscribing. 
Now I am stuck and unable to order physical sim, or do anything else because I cannot login to public mobile account anywhere.
the customer support agent is only forwarding public help articles and not understanding/ or unwilling to help.

I neither have esim nor I ever ordered physical sim, because while subscribing i selected esim.

what are my options here?


@VarunSikka   Yes, get physical sim from local Telus/Koodo/Mobile Klink store.  Call and check availability before you go

or via Amazon (Free Prime Shipping)

Do not try to order from PM site, it will take too long to arrive

Good Citizen / Bon Citoyen

@Handy1  I don’t have any esim installed, nor ever ordered a physical sim. I cannot reset it

Good Citizen / Bon Citoyen

Hi @hTideGnow 

I believe only option for me is to go to store and get a physical sim. I wasn’t able to install esim during subscription, and now my account is at the step where it assumes I have sim installed and asking me to verify my number.

@softec oops I mean @VarunSikka Call around to local Telus or Koodo store to see they have in stock , make life lil easier 

Good Citizen / Bon Citoyen

Yes, he just sent me a link to get a physical sim. I am looking at nearby locations where I can get a physical sim. 

I guess I have to visit the store (Telus store), no other option. 

@VarunSikka   so, you have been working with agent via messaging already ( i don't meant Chatbot, I meant message with agent via Community inbox)   

did they suggest you to change to phsyical sim?


Good Citizen / Bon Citoyen

Hi @softech 

It is a new account, and new subscription. I tried to send message to support agent. But they are not sending the esim QR code again, stating cannot resend without reactivation. While subscribing, i tried to install esim but was not able to install due to errors. And now my account says to verify the mobile number. It’s stuck at the step where the system assumes I have esim installed, but it was never installed. 


Mayor / Maire

HI @VarunSikka   not sure which step you are at with the eSIM activation. 

But if you got to the eSIM installation, try to reset all network.

If that doesn't help, then  submit a ticket with CS agent

Mayor / Maire

@VarunSikka  First try resetting network setting and see if that helps ,,, try and hit resend  fee time to see if you get option for email instead for verification and lastly support 

  • while your already here and logged in the community


  • you can send a private message   To CS_Agents by clicking >>>>>>>>here.


  Watch for reply top of page to the

   Right ( envelope image )


@VarunSikka you don't have any other line with PM using the same email address, do you?   Just a reminder, PM system is one email and one line.  If you are activating new lines, you need a different email

if the email part is not the reason, you will probably need support the look into the eSIM activation, possibly reset you a new QR code to install the eSIM profile

Private message CS agent at 
**Monitor your Community inbox (envelope icon on top right) after the ticket is opened.  CS Agent will reply to you there
Need Help? Let's chat.