cancel
Showing results for 
Search instead for 
Did you mean: 

I’m using data but it’s not coming from my new 15GB plan

frank44
Good Citizen / Bon Citoyen

I changed my account Nov 23 to the 15GB $40 plan.  The reason I selected that plan was that I had to temporarily move to another location without Wifi,  and I wanted to use my cellphone data for internet access.  With 15 GB I should have enough data to get my work done (acting as executor for a deceased family member in a distant city).

 

According to my phone I have used 8.3GB of data since Nov 23.  However according to the PM data for my account I used zero GB.  I think it’s using up my banked data add-ons instead of my plan data.

 

Why is this happening???  It should be using up data from my 15GB plan.  I want to keep my banked data ( add-on data) in reserve for a special situation, such as an unexpected stay in a hospital, etc.

6 REPLIES 6

kb_mv
Mayor / Maire

I have set my browser (Brave) to delete all browsing history, download history and cached data every time I quit. I have never had an issue with not seeing the correct data on my account and have never had to use incognito or private mode. Food for thought...


@frank44 wrote:

I logged into my account for the second time and yes, now it shows I used 8.03 GB data.  So, the account  situation is OK.  Not sure why it showed zero GB before, they should fix that, it cost me a half hour of time.


It's absolutely the most ridiculous thing. It sends people on wild goose chases looking at erroneous information. I prefer using the little spinner refresh icons lower down to refresh the info.

@frank44   yup.  Cache problem is a big issue for this new My Account site

 

So, always use Incognito mode to assure you are getting correct info

 

frank44
Good Citizen / Bon Citoyen

I logged into my account for the second time and yes, now it shows I used 8.03 GB data.  So, the account  situation is OK.  Not sure why it showed zero GB before, they should fix that, it cost me a half hour of time.

NDesai
Oracle
Oracle

@frank44 Try logging in to your self-serve account using incognito/private browsing mode. This might tell you an accurate status of your account. As long as you have data remaining in your plan, it should not use out of available data add-ons. 


_________________________________________________________________________________________________
I am not a mod. Do not send me private message with your personal info.
If you need to contact PM Customer Support Agent, create a Ticket.

softech
Mayor / Maire

@frank44   it could be just because you are still checking cached page and not live data from the server

 

Please try to access My Account again using Incognito mode and you should see the correct data.  Try it