cancel
Showing results for 
Search instead for 
Did you mean: 

Can't send SMS texts after updating to EMUI 10 (Android 10)

santipugo
Good Citizen / Bon Citoyen

Hey, so yesterday I updated my Huawei P30 to the new version of EMUI (based on Android 10). Since then, I can't send SMS texts but I can receive SMS, Calling and Data also works.

 

I tried all steps enumerated in this thread and nothing works:

 

https://productioncommunity.publicmobile.ca/t5/Getting-Started/Can-t-send-SMS-texts-but-can-receive-...

 

I removed the sim card from my phone, and put it in my family's iPhone 7 and Asus Zenfone, and in both cases I was able to send SMS texts. I tried changing the SMSC number for Public Mobile's one, which is 16475800172, but it was already set to that one. Below is a screenshot of what appears when I try sending a text.

 

Thank you for your responses on what I should do. 

 

*N'hésitez pas à répondre en français svp*

 

Screenshot_20200119_150421_com.google.android.apps.messaging.jpg

 

1 ACCEPTED SOLUTION

Accepted Solutions

ngomez
Good Citizen / Bon Citoyen

For anyone having the problem where you cannot send SMS after updating your P30 Pro to EMUI 10, I fixed it by doing the following (No device reset required).

Install the HiSuite app on your PC.  Set up your phone as instructed by following the screen prompts.

  1. Use HiSuite to backup (optional - I backed up just to have it done, but is not necessary)
  2. Use HiSuite’s App Manager to uninstall the Messages app (can’t be uninstalled on the phone)
  3. Use Play Store to reinstall Messenger.
  4. Use Messenger - SMS works.

SMS now works.  I hope that helps anyone else having the problem.

View solution in original post

27 REPLIES 27

ChuckYeah
Mayor / Maire

Try checking your APN Settings.

For Android, click:
Settings > More / More Networks / Wireless & Networks > Mobile/Cellular Networks > Access Point Names >

These are mine:

Name: Mobile Internet
APN: sp.mb.com
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://aliasredirect.net/proxy/mb/mmsc
MMS proxy: 74.49.0.18
MMS port: 80
MCC: 302
MNC: 220
Authentication type: Not set
APN type: default,mms,agps,supl,fota,hipri
APN protocol: IPv4
APN roaming protocol: IPv4
APN enable/disable: APN enabled
Bearer: Unspecified
MVNO type: GID
MVNO value: 4D4F 

@santipugo Also check and see if VoLTE is enabled. If so disable it. 

 

A google search uncovered this which may be the issue:

Scenario 3: An SMS message has been successfully sent, but the other party can't receive it.

You may be sending messages using Advanced messaging.

If your outgoing message box is blue, the message has been sent using Advanced messaging. Troubleshoot as follows:

Since the other party's phone may not support Advanced messaging, send a normal SMS message instead.

 

From huawei.com

@ChuckYeah Unless a texting app utilizes cellular data, APN setting are completely irrelevant to SMS. In fact, cellular data can be OFF and SMS would still function.

The only idea I have is: 

• Go to Settings

• Then go to Mobile networks and select a network other than Public Mobile, Telus, or Koodo

• When you exit the menu the phone should lose the network.

• Repeat the process and select Public Mobile as your mobile network.

 

@santipugo This should force a reset of the message centre settings. It won't fix an inheremt OS problem which you may have created. Hopefully an android guru can assist. 


>>> ALERT: I am not a CSA. Je ne suis pas un Agent du soutien à la clientèle.

Luddite
Oracle
Oracle

@santipugo Maybe you'd like to roll back to an earlier version that was bug free for you, and await the next version? https://huaweiadvices.com/downgrade-huawei-phone-from-android-10-emui-10-to-pie-emui-9-0-or-9-1/


>>> ALERT: I am not a CSA. Je ne suis pas un Agent du soutien à la clientèle.


@Luddite wrote:

@santipugo Maybe you'd like to roll back to an earlier version that was bug free for you, and await the next version? https://huaweiadvices.com/downgrade-huawei-phone-from-android-10-emui-10-to-pie-emui-9-0-or-9-1/


That's exactly what I was thinking, and you just made it a bit easier for the OP! 👍 

popping
Oracle
Oracle

@santipugo 

You tested your SIM card with another phone and sending text is wortking.  Therefore, it is not account related.  SMS message is sent by piggyback on the cellular voice channel.  Therefore, if voice call is working, SMS should work.

 

1.  Are you using Google Messages app?  If not, install and try it.

2.  Backup all your text messages and delete all messages.

3.  Clear messages app cache and forced close the messages app

4.  Do a network reset to set network related parameters to default.

5.  Backup your data.  Do a factory reset.

santipugo
Good Citizen / Bon Citoyen

These are mine, do you see anything wrong that I should try changing? 

Screenshot_20200119_160000_com.android.settings.jpg

 

santipugo
Good Citizen / Bon Citoyen

Do you know how to disable VoLTE on Huawei phones? I did a google search and the only thing I found is how to enable it 

santipugo
Good Citizen / Bon Citoyen

I followed your steps, forced it to use Videotron or Bell, and then came back to Public Mobile and it still doesn't work