Showing results for 
Search instead for 
Did you mean: 

Why can't I connect to the network

Good Citizen / Bon Citoyen

Since this afternoon I haven't been able to connect to the PM network. If I try to make a call it says "Not Registered on Network". I can send texts that take awhile but I can't receive anything or send messages to group texts. I have a ticket in and they tried refreshing my account and that didn't work. I want to go to sleep but also want this fixed and now it's been awhile since the CS person has replied. Any one have any suggestions, here is what I have tried so far that didn't work:

  • Restarting my phone
  • Resetting the network settings
  • Turning airplane mode on and off
  • I put my husband's PM sim card in my phone and it worked fine but when put mine back the problem came back.

I have had this phone for about 8 months and had PM the whole time. The problem just started today. I checked and my account is fully paid up. What else can I do?


Good Citizen / Bon Citoyen

@softech looks like an esim is possible for my phone. I installed the PM app and I will see if that works.

Editing to add that I just installed the esim on my phone and everything works again. I also sent another message to CS support to see if I could get that esim fee waived.

Good Citizen / Bon Citoyen

@Chalupa_Batman I tried doing that and when I selected Telus as my preferred network it wouldn't let me connect.


there is likely a problem with your sim card.  You might need to get a new one (you can get a PM sim card from Amazon for $5 or local Telus/Koodo store for $10)

Tell what you found from all these tests  to support agent when they reply and ask them to reimburse you the sim replacement cost.


Good Citizen / Bon Citoyen

@softech the account is active. 

I just tried putting the SIM in his phone and when I do it doesn't even recognize that there is a SIM card. But when it is in my phone it recognizes that there is a SIM and even knows the phone number. But it just says it's an unknown SIM.


when you logged in My Account, does it show your account is currently active?

I understand you tried to put your husband sim card into your phone and test, but can you do it the other way? Put your sim card in your husband's phone.  By doing so, it will for a sim reprovision and it could resolve the issue


Good Citizen / Bon Citoyen

I checked the SIM number and it matches the one in my account.

And looking at your note about the support agent hours it looks like they are closed so if anyone else has any suggestions for how I can fix this myself it would be very helpful.

Mayor / Maire

Hey @pilkster21 

This this. Sounds odd, but just wondering if this fixes it. Go to your network settings. Turn off Automatic and choose Public Mobile. Then reboot. See what that does.

Deputy Mayor / Adjoint au Maire

@pilkster21 - Also have you tried logging in and seeing if your SIM number matches the one listed on the Profile within My Account and the one that you have inserted in your device?

Try to contact CS_Agent again or ask to escalate it up to the Manager (The Needed thing to do to probably get it fixed):

Submit a ticket via Chatbot:

⚠️ Public Mobile is Experiencing longer support wait times currently! Do Not Reply back to CS_Agent after submitting your ticket unless you solved it! Click here to bring up the Article!   ⚠️  


If you just want it quick and easy, here it is:

⬇️  Click the link for an Agent * ⬇️

If the link above doesn’t work correctly OR you don’t have access to Log In, please go here to create a ticket to CS_Agent:

* - CS_Agent will typically get back to you within 48 hours. They work 7 days a week from 9 AM to 10 PM EST.  You will be required to login to your Public Mobile Community Account to contact CS_Agent. Once you are finished making the ticket with CS_Agent, please ensure that you monitor for one of the agents responding back to you because they may notify you asking for some information via Private Message, in your community mailbox by clicking this link here: Mailbox

Need Help? Let's chat.