Showing results for 
Search instead for 
Did you mean: 

Unable to send MMS messages

Good Citizen / Bon Citoyen

I have an iPhone and it will not let me send MMS messages with pictures. I have tried everything suggested in every community post to no avail. I'm confident it is an issue with PM, as if I swap out the SIM with one from Rogers, MMS works fine (without adjusting any other settings). I tried opening a ticket with support but it keeps giving me a 404 error, so I'm hoping someone can send me a DM to assist with this issue.


thanks @For confirming

Yes there was a post regarding old devices and MMS.  But with different app these days, just sent with iMessage or WhatsApp. It takes a bit of mobile data but less headache (or you can send via Wifi without using data)

Good Citizen / Bon Citoyen

The agent already confirmed that the new APN will not make a difference. Telus has disabled the MMS proxy for legacy devices, including my iPhone 6. I need to upgrade the hardware or switch to a different carrier, although the other carriers are ending MMS support for legacy devices soon as well.

hi @airdriewheels try message support and ask them to refresh the account

There was another had the APN updated but the agent checked and confirm the phone still connected to the old server, support agent needs to refresh to help

  please submit a ticket with CS Agent here:

Good Citizen / Bon Citoyen

Yep, tried the new APN, still didn't work. Looks like it's iMessage or a third-party app in order to send pictures.

Hi @airdriewheels but did you try the new APN??

If still does not work, you have to use iMessage or WhatsApp to send pics 

Good Citizen / Bon Citoyen

Figured it out. It is an iPhone 6, so the carrier doesn't support MMS for the device any more. It's awesome that these older devices which are still fully functional get rendered useless by network upgrades and essentially force customers to purchase new hardware.

Try these APN settings, @airdriewheels 

MMSC proxy:
MMS port: 8799
MCC: 302
MNC: 220
APN Type: default,supl,mms
                             or             default,mms,agps,supl,fota,hipri

Good Citizen / Bon Citoyen

I'm using the native messaging app on the iPhone and I've disabled iMessage and set it to MMS only. A different SIM in the same iPhone (from a different carrier) allows me to send MMS.

It all depends do you use proprietary apple apps or Native texting app.

If app has 'i' in front of name must be apple stuff. Try to find native app and use it.
On Android most likely you did use NATIVE texting app and of course it worked as it is supposed to work.

Turn off your iMessage and use MMS only.

If you have a data connection, (you don't even need remaining data) then MMS will work.

Try resetting your APN connections.



Good Citizen / Bon Citoyen

All other features work as expected. Incoming/outgoing calls, SMS, web browsing etc. I also tried the SIM in another device (Android) and I was able to send MMS picture messages with it, so it must be combo of this iPhone and Public Mobile. I was able to send a private message to CSA per your instructions, thanks!

Mayor / Maire

Hi @airdriewheels tested your PM sim on another phone? If same, please submit a ticket with CS Agent here:

Mayor / Maire

Before going any further, does your SMS texting work in and out, @airdriewheels 

And calling both in and out?  And data?

If you require customer support, here's the only way to reach public mobile staff for assistance.

To contact a Customer Support Agent, send a private message to them by clicking here.  You’ll need to be logged into your Community account for the link to work.

Watch for their response in your Community private mailbox which will be indicated by a number on the small envelope icon to the left of your Community avatar, or tap your Avatar down in Messages.


Need Help? Let's chat.