cancel
Showing results for 
Search instead for 
Did you mean: 

US data add on not working & Canadian data not working

Tatiana3
Great Neighbour / Super Voisin

Hello. I live in Canada and I have a monthly data plan by Public Mobile since 2021.

 

I travelled to The US recently and I purchased a 10 days US data add on for which I was charged $20CAD. However, the plan never worked during my whole stay and I did not have any data during my whole trip! I also tried to call 611 or ask for the refund on your website, but there is no such option!

 

On the top of that, I just came back to Canada and my Canadian data is not working, even though I still should have 1,15GB available.

 

Please help me to activate my current data asap and send me the refund for the US add on, thank you.

Tatiana

1 ACCEPTED SOLUTION

Accepted Solutions

hairbag1
Mayor / Maire

Log in to your account  to see how much data you have available to use....Have you tinkered with APN settings recently ?

On your trip...did you ensure Cellular Data Roaming was enabled ? ...won't work without it.

You can ask the CSR to credit your acct the $20 for the 10 Day US Roaming add-on you had...

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

 

Watch the envelop icon on top right side of page will be highlighted when they respond.

View solution in original post

3 REPLIES 3

Timer
Model Citizen / Citoyen Modèle

@Tatiana3 

contact support team by  CS_Agent  to check those add-ons or get credit.

hairbag1
Mayor / Maire

Log in to your account  to see how much data you have available to use....Have you tinkered with APN settings recently ?

On your trip...did you ensure Cellular Data Roaming was enabled ? ...won't work without it.

You can ask the CSR to credit your acct the $20 for the 10 Day US Roaming add-on you had...

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

 

Watch the envelop icon on top right side of page will be highlighted when they respond.

will13am
Oracle
Oracle

@Tatiana3 check your phone to make sure it is set to auto connect to mobile networks.  Check that usage limits on the phone if set are not reached.