Showing results for 
Search instead for 
Did you mean: 

I can't log into my account and I can't change the visa payment

Great Neighbour / Super Voisin

Good morning. I signed up with Public Mobile yesterday, and everything was working well last night. However, this morning, nothing is working. I am getting the A1 forbidden message. I cannot log into my account. I need to change my credit card information as last night my credit card was compromised, therefore I need to update my credit card information for the payment. 

I hope to hear from you soon. 


Great Neighbour / Super Voisin


I have tried everything mentioned above. On my labtob I still get A1 error and on my phone app after entering the security code it brings me back to the login screen. I am hoping you can help.


Mayor / Maire


Login on the PM app tap the Payment tab>Change Card Information.


Mayor / Maire

Try using computer and very clean browser. Incognito/private mode might help.

Wait 1h before trying again. If you try too many times your account might be temporary blocked due to suspicious card fraud attempt. Then you would need agents assistance, ticket, etc.

Mayor / Maire

HI @Terese 

plesae try again using incognito/private/secret mode on your browser, if fails, try using Public Mobile app

if both don't work, you will need to ask agent to help with login and you can then update the card yourself

  please submit a ticket with CS Agent using this Chatbot link:  Type the question "Submit ticket", Then click the following in order: "Contact Us" ,  "Other",  "Log In".  
If any issue with ticket submission, you can  submit by direct message:        

Need Help? Let's chat.