cancel
Showing results for 
Search instead for 
Did you mean: 

5G IPhone13 Pro

Cdn_bacon
Great Neighbour / Super Voisin

I’m a new customer to public mobile and signed up for a Black Friday plan for 5G. Checked the coverage map and my city is well covered (Saint John, NB). 
I have an iPhone13Pro and switched caller voice & data to “5G on” and data mode to “allow more data on 5G”

for whatever reason my phone doesn’t seem to want to connect to the 5G network and I’m at a loss. Also doing a speed test on LTE I’m only getting 14mbps down. Bit disappointing really and wondering if it’s something I haven’t setup correctly? 

5 REPLIES 5

Cdn_bacon
Great Neighbour / Super Voisin

Got it to work. Apparently it was just my impatience and being in a part of the city that didn’t have 5G coverage.  A drive home across town and it connected. 

assume by going back to 5G Auto it will mainly switch to LTE and only pull 5G when needed? And help save on battery. 

dwh1
Model Citizen / Citoyen Modèle

Another thing to try.  Go into Settings/General/About.  That might trigger an update to the carrier profile and help.  No guarantees though.

Just a long shot. Go into your network settings and turn off automatic and pick Public Mobile then reboot and do a speed test.

Cdn_bacon
Great Neighbour / Super Voisin

It is on. Reset phone but no luck. 

hTideGnow
Mayor / Maire

hi @Cdn_bacon 

try changing the Network mode to 5G On and test but it will consume more power

After test, best to change to 5G On , better for you battery 

Need Help? Let's chat.