cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Great Neighbour / Super Voisin

Made a payment...still no service

Super frustrated at this point...didn't have minutes for just over two months on my phone...but my dissconect date was Jan 28th...put minutes successfully on my phone yesterday or the day before...and it took my money...and shows I still have a $13 balance...after doing that...I realized calling, texting, and data wasn't working...so I went into my account and changed my plan...now it still shows that plan I chose as the plan I have...but when I try to make any call local or not it says I don't have a long distance add on...and still will not allow me to call,text, or use data...but shows I have an active plan...I have sent two messages to the mods and nothing...starting to consider switching providers at this point...can ANYONE HELP ME???

Town Hero / Héro de la Ville

Re: Made a payment...still no service

@14peckerwood88

Sound complicated.....if you can post a screenshot of your account payment details..block out personal info ...

Mayor / Maire

Re: Made a payment...still no service

@14peckerwood88

If your plan is active in your self service account and your service is not working, you could try the lost/stolen phone trick.  It seems to reset your SIM card and re-activates your plan. 

 

https://productioncommunity.publicmobile.ca/t5/Paying-for-your-service/SOLUTION-My-plan-has-enough-f...

Great Neighbour / Super Voisin

Re: Made a payment...still no service

IMG_4213.JPG

 

Great Neighbour / Super Voisin

Re: Made a payment...still no service

IMG_4213.JPG

 

Mayor / Maire

Re: Made a payment...still no service

@14peckerwood88

As stated above, try the lost/stolen phone trick.  It seems to work for other customers in your situation in the past.  

 

Login to your account.  Choose Plans and Add-onstab. Then choose Lost/Stolen Phone tab.  The choose Suspend Service tab.  Logout.  Login after a few minutes and report your phone found.  Reboot your phone and your plan should start working.  
 
Tags (1)
Great Neighbour / Super Voisin

Re: Made a payment...still no service

nope that didn't work either...i have also tried putting the sim card into my old ladies phone and still nothing

Tags (1)
Deputy Mayor / Adjoint au Maire

Re: Made a payment...still no service

Since it doesnt work on other working pubic mobile phone, the sim card doesnt work .

Mayor / Maire

Re: Made a payment...still no service


@14peckerwood88 wrote:

Super frustrated at this point...didn't have minutes for just over two months on my phone...but my dissconect date was Jan 28th...put minutes successfully on my phone yesterday or the day before...and it took my money...and shows I still have a $13 balance...after doing that...I realized calling, texting, and data wasn't working...so I went into my account and changed my plan...now it still shows that plan I chose as the plan I have...but when I try to make any call local or not it says I don't have a long distance add on...and still will not allow me to call,text, or use data...but shows I have an active plan...I have sent two messages to the mods and nothing...starting to consider switching providers at this point...can ANYONE HELP ME???


Hi, first thing I will say is to never wait 2 months for something that isn't working properly to ask for assistance.

Secondly do not change your plan to fix some part of your plan that isn't working. (this usually results in losing your previous plan allotment.)

Third thing is to explain your issue with as much detail as you can possibly give. (more is better).

There are a few tricks to try. Lost/stolen as mentioned and I found recently while doing my wife's account that even though the Lost/Stolen did not work, adding a $1 to her account did.

 

If either response to your particular request leads to the resolution of your issue , please help other community members by marking that post as the solution. Thank You

Mayor / Maire

Re: Made a payment...still no service


@14peckerwood88 wrote:

nope that didn't work either...i have also tried putting the sim card into my old ladies phone and still nothing


Just curious, did you purchase the phone from someone other than a retailer and when?