cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Great Neighbour / Super Voisin

Re: AutoPay did not process by due date and service is now inactive

Messaging the mods rectified the issue as of noon today. There was a little delay due to an authentication process and waiting for a subsequent reply.

 

The problem definitely stemmed from the billing system as my credit card company confirmed everything was OK on their end. They also confirmed no Public Mobile transactions were attempted on the Autopay day nor the day after when I lost service.

 

I think I was credited the month for the inconvenience. Otherwise I'd have jumped ship.

 

Thank you all for your help. Smiley Happy

DrD
Great Neighbour / Super Voisin

Re: AutoPay did not process by due date and service is now inactive

Same propblem here!!

Tried to login my account but site is unresponsive.

 

DrD
Great Neighbour / Super Voisin

Re: AutoPay did not process by due date and service is now inactive

Look like publicmobile site is down!! or hacked...

Town Hero / Héro de la Ville

Re: AutoPay did not process by due date and service is now inactive


@DrD wrote:

Look like publicmobile site is down!! or hacked...


@DrD  No, that's not it. I am able to access it and login into my account just now.Smiley Happy

Great Neighbour / Super Voisin

Re: AutoPay did not process by due date and service is now inactive

I've got the same problem. I messaged the mods, but if you don't have time to wait for a response, I was able to get it working by changing plan and making a manual payment, so that might work if you need a quick fix.