cancel
Showing results for 
Search instead for 
Did you mean: 

"Plan expired" despite an autopayment yesterday

tommygun
Good Citizen / Bon Citoyen

Payment went through, can see it on my CC statement. However, still got a text that my card was declined. Today my data and texting haven't been working *even though I've paid.* I haven't checked but I doubt calling is working either. My texts don't say that they weren't sent, but they aren't received by anyone. All websites return "Website not found" regardless of whether I'm on LTE or WCDMA. Alberta, SE of Calgary. Anyone know what's up?

 

EDIT: Also, attempting to top up to reactivate returns "Your account has enough funds already" or something like that. Which is true; I have $30 on my account which should cover my plans after rewards. Also, I cannot access my rewards. Brings me to a Telus login page which breaks after putting in my Publicmobile credentials.

10 REPLIES 10

MrSpock
Great Citizen / Super Citoyen

@tommygun Hello since your funds are in your account look for the reactivate button In your account press it reboot your phone and hopefully you will have service

Yummy
Mayor / Maire

If you manually paid, try to log off/log in and reboot your phone. You should see 'reactivate' service button.

If it doesn't reactivate then go to the plans or usage page and click on the lost/stolen option. Suspend your service. Log-out/in. Resume your service. Your plan should automatically reactivate.

 

Rewards page works as expected. Just tried and was able to log in. Try different browser or incognito mode.

Does your account says Active or Suspended?

 

softech
Mayor / Maire

@tommygun   , so your account still showing Suspended?

 

Try to use the Lost/Stolen trick to force a renewal:

 

Login to My Account.
Go to Plan and Add-ons Tab and click on Lost/Stolen Phone to Suspend the service.
Log off and then Wait 5 minutes
Log back in My Account, go back to Plan and Add-ons Tab, click on Lost/Stolen Phone, then Resume/Reactivate Service. The plan will automatically reactivate since you already have enough funds to pay for the plan.

 

tommygun
Good Citizen / Bon Citoyen

Okay, got it working. Added $10 instead of "Amount due" (was $0.00) and it reactivated. Weird thing though: it now says that my plan is $10 even though it's $40 before rewards and $30 after rewards. It also says that I have no available funds despite the $10 payment just now.

@tommygun   Yes, Amount Due option sometimes give problem

So, your account is not Acitve?

@tommygun 

 

The $10 top up isn't supposed to show in yout available funds. This is because that $10 has already been used to pay for your plan.  This issue here is entirely with Public Mobile not using pre-authorized payments to charge the correct amount.

tommygun
Good Citizen / Bon Citoyen

I'm not certain that's the case. I've never had issues with payment before now and before paying the $10 there was no amount due and a $30 credit on my account.

dust2dust
Model Citizen / Citoyen Modèle

Maybe you could provide us with an image of your payment history. Here, not the credit card.

tommygun
Good Citizen / Bon Citoyen

Screenshot_2022-06-23-18-01-10-1.png

Looking at it, it seems that it autopaid $21 instead of $31 which accounts for that $10. Yet, my credit card statement says $30. I'm pure confused.