Showing results for 
Search instead for 
Did you mean: 

Question about log in problem

Great Neighbour / Super Voisin

Hi I just want to ask how can I talk to a customer service representative here about log in problem?Im just wondering why I cant log in.I tried many time but still no luck.Also I tried the send security code option but its not even sending me code via my email or mobile number.Please help.Thank you


Mayor / Maire

Here’s another possibility, @mikeskie 


if you are using a mobile device on Google Chrome, and you have remembered credentials, let the credentials auto populate and the system will automatically try to log you in.


If you press the login button while this is occurring, you will receive an error message every time.

Mayor / Maire

@mikeskie you checked your spam folder?


you can open ticket with PM support and have them to assist


If that still does not work, then open ticket with PM support using Charbot and they will sort it out for you


1.  Open ticket with Chatbot for faster response (2-48 hours), using direct link:

Start by typing "Forgot Login Information", then click "Contact Us",, then click "Click here to submit a ticket ↗" 

2. if you have problem with Chatbot: Private message CS Agent at:

**Monitor your Community inbox (envelope icon on the top right) after the ticket is opened. CS Agent will reply to you there


Town Hero / Héro de la Ville

@mikeskie @Try again in incognito mode  private mode there are cache issues or try a different device lap top 

Mayor / Maire

There has been issues reported this morning similar to this, I wonder if you are the same @mikeskie 

Did you just activate a SIM card or have you been a customer previously and were able to log in before.


Submit a ticket to CSA if you just activated and are having issues. There were updates made, sounds like possible blimps happening. ­­­Public Mobile Representatives customer support­­­ agents (CSA) can be contacted by either two methods, found here:

Mayor / Maire

@mikeskie   Are you using incognito or private mode to login?  PM has a terrible issue with caching so clear cookies or use another browser if necessary.  Not sure why you're not receiving the security code option though.