Showing results for 
Search instead for 
Did you mean: 

Porting number from Bell

Great Neighbour / Super Voisin

I initiated a request to port my number from Bell when activating my new Public Mobile SIM card. I got the SMS requesting permission and said yes. Nothing else happened. When I called Bell and asked them to re-initiate the porting, they said it had to come from Public Mobile. I tried to submit an IT ticket, but get a 404 error each time. Also tried to send a public message, but that is not working either. Please help! 


Mayor / Maire


Please note that the Bell SIM will continue to work until the porting process is completed. This may take up to 2 hours.

Then power off your phone and switch the SIMs and power back on the phone.

The PM SIM should be working by now.

Mayor / Maire

@Wendy-12  - i got the 404 message too with SIMon Bot just now...?


Contact Public Mobile Representatives (CSA) by submitting a message(ticket) to them here: 

Private Message to Public Mobile Customer Support Agents (CSA)



EDIT, not sure if you were having issues with private messaging or not from your post...I was able to see the private message option to CS_Agent just fine.

But if still issues, you can try calling the Telus porting phone number, which we are not supposed to post here. So, check your private messages I will send it to you there.