cancel
Showing results for 
Search instead for 
Did you mean: 

Porting a number from Telus to PM

Bill31
Good Citizen / Bon Citoyen

I went through the process of porting my number from Telus to PM. I have confirmed to Telus that I agree with the transfer. The number appears in the account tab of the PM app. I have setup my recorded message. I can make calls with the ported number.

But, after over 4 hours, I can't receive any calls. Nothing happens; they don't even go to voice mail. I haven't received the confirmation message from PM that the process has been completed. I thought that it would be all done in 3 hours or less.

Can it take more than 4 hours or is it stuck?

Thank you for any help.

6 REPLIES 6

Bill31
Good Citizen / Bon Citoyen

Can you tell me where the Reset All Networks option is located?

 

Bill31
Good Citizen / Bon Citoyen

I can try a reboot but I'll have to wait until tomorrow to test it because my "caller" on the other end has gone to bed. I only have one phone here.

Thank you for the phone numbers. 

 

@Bill31 

it's not an issue with the phone, just some setup problem

After you put your PM sim card back into the phone, also try Reset All Networks and see if it that helps.  If not, best to contact PM porting team to confirm porting status 

I tried the Telus SIM back in the phone but it no longer works.

The PM worked with the previous number before porting so I imagine there is no issue with the phone?

Just wondering, if you put your Telus SIM back in your phone, does it still work? Did you try your Public Mobile SIM in a different phone?

@Bill31 did you try reboot your phone? Usually you need one more reboot after the port is completed

and if that does not work yet, There is a number to call to talk to live support (but they are closed now, you need to call tomorrow after 9am EST)  They can confirm the port status.  I will message the number to you via the Community inbox ( https://productioncommunity.publicmobile.ca/t5/notes/privatenotespage ) .  Check the envelope icon on top right.  Call them and get it fixe

Need Help? Let's chat.