cancel
Showing results for 
Search instead for 
Did you mean: 

No Mobile Data!! same question no solution!?!?!??!

kaan
Good Citizen / Bon Citoyen

hello to all who are willing to offer help and others who are desperatley looking for a solution in this forum!!

 

I just switcched to Public Mobile with a plan that includes Voice, text and DATA.. I activated my plan; I receive calls and can make calls. BUT i do not have internet connection on my phone. Basically NO MOBILE DATA!  however when i put my sim card into my old phone (samsung) it works perfectly...  my new phone is ZTE AXON A1R and OS is ANDROID 6.0.1

 

I did numerous factory resets. reset the APN. but no luck!! dont ask me if the mobile data is on!! yes it is on.. airplane mode is off and my phone is active including data and I know my phone was working just fine with my previous service provider. So it is not my phone..  it is not the sim card.. it is that some unknown godly power up there until we figure this out!!! tahnk you very much for your responses in advance.. 

1 ACCEPTED SOLUTION

Accepted Solutions

kaan
Good Citizen / Bon Citoyen

@imcphers wrote:

Just setup an Axon 7 this evening.  Everything was read correctly from the PM SIM card except one field.

 

MNVO value was initially set to 50 and the LTE data would not connect.

 

Change MNVO to 4D4F and LTE started working right away.

 

This thread also highlights the importance of this field.....

 

http://productioncommunity.publicmobile.ca/t5/Plans-Add-Ons/Mobile-Data-Not-Working-APN-seems-to-loo...

View solution in original post

41 REPLIES 41

Dunkman
Oracle
Oracle

 

@kaan

Sorry to hear about your troubles.  If your PM SIM work in another phone, it should be some setting issues with your phone.  

 

Here is another thread with some suggestions with the same model phone:

https://productioncommunity.publicmobile.ca/t5/Phones-Hardware/Data-not-working-on-ZTE-Axon/m-p/2003...

mimmo
Oracle
Oracle

If data works in your samsung and not your zte, the i would say it a phone issue.  that being said searching tor forums for zte axon, one solution mentioned is to keep the phone on for a couple hours after restart.  have you tried that?

 

https://productioncommunity.publicmobile.ca/t5/Getting-Started/No-LTE-on-ZTE-Axon-7-downtown-Vancouv...

 

Edit in the link posted by @Dunkman  one of the posts suggests including  default,supl,mms in the APN type field.    

kaan
Good Citizen / Bon Citoyen

my phone has been on for the last 2 days.. But you might be right.. it must be the settings even though I tried every possible APN settings out there.

 

on a side note , I cancelled my data service with my previous service provider and i wonder if it has anything to do with that as I transferred my old phone number.. which would be absurd but I cannot think of anything else.. othwerwise my ZTE was working with mobile data before..

 

I appreciate your time 🙂

 

It definitely can be frustrating...  APN settings can be tricky at times.  Even upper and lower caps make a difference.  

 

You may want to contact moderator to see whether they can help.  It will take 1-2 days for response time.  

 

send a private message through the following link :

https://productioncommunity.publicmobile.ca/t5/notes/composepage/note-to-user-id/22437

Please include in the private message your phone number, your account number and PIN code.

Sameer_aslami
Great Neighbour / Super Voisin

I had the same issue and I realized my previous account number was wrong and when I was able to find the right account number, it was fixed right away. You can send it to moderator.

@Sameer_aslami what does an account number have to do with data? Data works fine in the Samsung phone and all other services work.

So it's not a porting issue.

hey @kaan if modifing the apn as described in one of the posts does not work.  I know you  have done factory resets, I would  possiblt try two factory rests back to back  and  I would  try clearing the cache partitions via the recovery console(if you are comfortable with that), these should be cleared with factory resets but you i have seen stranger things....   again I am just shooting in the dark....

kaan
Good Citizen / Bon Citoyen

thank you.. i will give it a try.. i m sure it is a some kind of setting issue with the phone.. thank you again..

NewZQ
Great Citizen / Super Citoyen

Could it be that the ZTE AXON A1R does not have the necessary bands for LTE ? you tried prefer 3g network ?