Showing results for 
Search instead for 
Did you mean: 

Just activated, issues with service already

Good Citizen / Bon Citoyen


Q1: How do I direct message CS_Agent? The person I spoke to on the website told me to do this to ask my question, have no idea how to do that.

Q2: I just activated my partner's new account. His phone is showing 1 bar, which keeps dropping to 0 (no service). We keep trying to test phone calls, which are intermittently working. Why is this happening and how to fix it. 

PS: I signed up for public last year and had this exact issue. Nobody could call me, and I couldn't call out. I had many people trying to help troubleshoot via community and nothing ever helped so I had to give up and switch providers right after. It was extremely frustrating and have never experienced such a thing prior to that. To note, we live in a small town but we are not remote. Previously I was with Telus, and am now with Rogers, and had/have near to full service without interruption. Public is the anomaly. 

Appreciate any help, thanks. 



yeah initial setups especially with new numbers always seem to have issues... ask customer support to reset the network on their end and/or reprovision the account. iPhone6 is pretty old I would try to test it on one of the newer devices first to ensure the signal quality is up to par. I don't believe iPhone 6 qualifies for volte at PM which could be one of the reasons the calls drop on that device. the device is trying to make a call only through 3g and 3g is being decommissioned... 

try the sim in your device and make sure when you make a call that "LTE" is showing in your notifications bar. if it says 3g or hspa then volte is not enabled 

@Amandae12   What happens if you put your sim in his phone?

HI @Amandae12 

it sound like a phone issue.  I am a bit confused, so, the problem is on iPhone 11 or iPhone 6?

is iOS updated? how about Carrier profile?


Good Citizen / Bon Citoyen

I should specify, it worked for the time I had it in my phone. When it is in my partners phone it will work and then it won't work. It drops all service, or it has 1 bar. When it was in my phone it had 1 bar, so I suspect if I had it in there longer I may have seen the same response of losing service and it not working. My suspicion is it is not the phone, even though it is old, because as I said, I had the same issue last year and my phone is an 11. 

"2. when I put the sim in my phone it seems to work,"

That suggests that it's the phone that is the problem

Good Citizen / Bon Citoyen

I would assume all providers are plug and play, how does Public differ? 

Good Citizen / Bon Citoyen

Thank you for your message and thank you for the link. 

1. He can intermittently make and receive phone calls. He just tried calling me and it takes a while to connect (this happened to me last year when I was having the same issue). Othertimes it is not working, both ways. 
2. when I put the sim in my phone it seems to work, I tried 2 outbound calls and they both worked without hesitation, although the service is 1 bar in my phone as well, where my own (Rogers) has 3.

3. I have reset network settings. No, it does not work. I tried to call my phone and it says "call failed" (again, same thing that happened to me last year..)

4. Iphone 6. He has an Iphone 11, but it isn't usable, so we had to pull the old one out of the drawer for now. 


PM is not really a plug and play phone company so you will need to do your due diligence and learn how the system works otherwise you may be in for a rude awakening. the good thing is there are very knowledgeable and helpful customers in the community. always come to community first and ask just to avoid potential issues

Good Citizen / Bon Citoyen

Thank you for your quick response.

I'm surprised I signed up again too! But I figured, it's a different phone and I had imported a previous number and he is getting a new one. I wasn't sure if the issue was my previous number since it originates from a remote location. Either way, I figured it should work with a local number, so here I am trying again. 

He won't be receiving a message of disconnected service from a previous provider since he didn't have one. Long story, he's just been using wi-fi and a free phone number for a long time, so he won't be getting a confirmation of disconnection. 

I appreciate the link, I will use that, and will try resetting the network. Will update if that works. 

Mayor / Maire


1. direct message:

2. your partner's phone, can it make outbound calls? how about inbound?

Test the sim card in your phone, does it work?

Put it back the partner's phone, click Reset All networks and does it work

Finally, what phone model is that?


Mayor / Maire


I'm surprised you decided to reactivate...

*customer support doesn't always respond promptly. please be patient and check your inbox every few hours to see if there is a response

CSA are available from
- Monday to Friday: 6AM- 10PM EST
- Saturday and Sunday: 6AM- 10PM EST  

provide as much info as possible as speaking with customer support isn't an instant message type of communication

as for your partner try resetting their network settings and then restart the device. you can also remove(wait for 5 min) and reinstall the sim while the device is off

did you reactivate the sim correctly? there is a text that should come in from the previous provider confirming the transfer to public mobile. 

Need Help? Let's chat.