Showing results for 
Search instead for 
Did you mean: 

Help :( Just switched from Bell, can't make or receive calls, can't send or receive text messages

Great Neighbour / Super Voisin

Hi everyone, as a brand new Public Mobile customer, I need some help please!

My wife and I have been Bell customers for many years but I got tired of paying $100 per line for basic service, so I tried signing up to Public Mobile and porting my number last night. I signed up for the $34 plan, and got an email confirmation, and the payment has been charged.

The eSim and setup process from my phone (zflip5) all went well and everything said it was done, then I got a message from Bell asking me if I wanted to port my number, to which I replied 'YES', which then deleted my account completely, and instantly from Bell. On my phone then I switched from SIM (Bell) to eSim (Public Mobile) and reboot, and now my service provider says Public Mobile (Telus).

However, I cannot receive or make calls, and I cannot send or receive SMS messages except for from Public Mobile for the EverSafe account login. Furthermore, whenever I try to login to my account online or through the App I get an 'A1 Forbidden' error, despite constant refreshes, uninstall and re-install of the app.

The only number I can dial is the *611 (as instructed whenever I try to make a call and can't), but the only person who I ever managed to reach didn't know what I was talking about and didn't know what Public Mobile was?

I also sent @CS_Agent a message but haven't heard back yet.

I use my phone for work for 2fa, and to login to basically everything, so this is a massive issue for me : (

Does anyone have any advice?

Thank you.


Great Neighbour / Super Voisin

Call bell and see if the port was accepted. You have to respond yes within 90 mins I belive. Also I would try resetting the network. And then a phone reset

Great Neighbour / Super Voisin

Thank you! Public Mobile was able to solve the issue for me just now, everything is working perfectly.

Thank you for all of your help today.

@Milleh  Perhaps now is the time to call the porting team, I will private message you the number, although it may say not eligible to port because it's already been ported and something went wrong somewhere.

Great Neighbour / Super Voisin

Update! Good news is that I was contacted by support and they assigned me a temporary number, so now I can make and receive calls as well as text messages. I am also able to sign into my account now, yay!

Bad news is I was told my number was not ported even though I did port it during the sign up process with Public Mobile last night, and when I did that last night I received a text from Bell asking me to confirm port and I replied 'YES' to port. Now when I try to port it from my account, because that's what I've been asked to do, it says number not eligible for port


@golfball wrote:

Would this situation be considered an appropriate time to call the porting team?

Unfortunately, this is the type of case that the porting team should not be contacted about.  The inability to send outgoing text messages and the inability to make outgoing phone calls is unrelated to number porting.

Town Hero / Héro de la Ville

Would this situation be considered an appropriate time to call the porting team?

Great Neighbour / Super Voisin

Good morning! Thank you for the tip, I hadn't tried that yet, I just physically removed the SIM card and restarted but the issue persists. At least that's something I hadn't tried crossed off my list though.

I also wasn't aware of what the customer service hours were either, so thank you for that information. I'll wait and hopefully they can get back to me sometime soon.

Mayor / Maire

@Milleh   Have you tried removing the Bell sim?  Customer service hours are 9 a.m. to 10 p.m. so hopefully they will get back to you soon.  

Need Help? Let's chat.