Showing results for 
Search instead for 
Did you mean: 

Can't send or receive texts

Great Neighbour / Super Voisin

I transferred my phone number from Freedom Mobile to Public Mobile about 22 hours ago.  I can now phone and receive phone calls, but I can't send or receive texts.  I have tried powering down and powering up my Samsung Galaxy S10, but that didn't solve the problem.  I also upgraded to the latest version of Android 11 (One UI 3), but still no text messaging.  Is there something else I can do?


Mayor / Maire

hi @Garbonzo yes PM has some issue with text on new activation. But PM support cam fix it, please submit a ticket with CS Agent using this Chatbot link:  Type the question "Submit ticket", Then click the following in order: "Contact Us" ,  "Other",  "Log In".  
If any issue with ticket submission, you can  submit by direct message: 

Mayor / Maire

Public Mobile is dealing with issues when it comes to SMS on Android and iMessages and FaceTime and such. There is no ETA of when it will be resolved. Here is their announcement.

Hey Community,

We are aware that some of you are currently unable to successfully use iMessage and or FaceTime features,  and we understand how frustrating this can be. Our teams are working diligently to find the cause. 

In the meantime, please try troubleshoot steps:
Tap Settings > General > Transfer or Reset [Device] > Reset > Reset Network Settings.

We apologize for any inconvenience this may have caused and will continue to keep you updated. 

Thank you,

  • Public Mobile Team

Keep an eye on this thread as they SHOULD update it when things are fixed.

Need Help? Let's chat.