Showing results for 
Search instead for 
Did you mean: 

Can’t call or receive calls

Great Neighbour / Super Voisin


I recently changed my public mobile plan online, from a Canada plan to a Canada-USA plan right before I travelled to the USA (on Sunday). For the first half a day or so the calling worked fine, but now if I try to call it hangs up immediately and if someone calls me it goes immediately to voicemail. I’ve tried restarting and not sure what the problem is, my data is working fine so it’s not the biggest inconvenience at the moment. 
I tried submitting a ticket, but when it prompted me to choose a nickname it kept saying there was an error, so I posted here. Been with public mobile for years and never had an issue before 🙂


thanks to whoever is able to help me with this!


Great Neighbour / Super Voisin

Not sure if I can close this, but this has been solved! I had to switch to T-Mobile manually. Thanks everyone for the replies 

@Derek14  iPhone 7 is not on the PM VoLTE enabled list so that may be the problem.  If it is you need to connect to T-Mobile because AT&T will not work.  

Great Neighbour / Super Voisin

I have an iPhone 7, and am connected to AT&T LTE. I’ll try the link AK32 sent to contact someone. Thank you for the replies!

Mayor / Maire

@Derek14   What phone do you have?  If it's a non-VoLTE phone then perhaps you went in and then out of a T-Mobile 2G area.  The same can also happen with 5G as already mentioned, it works on T-Mobile but not AT&T so safest to go with 4G/LTE.  Also make sure your phone is not trying to use Verizon since that is not a roaming partner of Public Mobile.

Mayor / Maire

@Derek14  If you are in the US now set phone to 4G/LTE. Not 5G and connect to T mobile or AT&T . Also ensure you have data roaming turned on in phone settings 

Model Citizen / Citoyen Modèle

That is strange that it worked fine after you made the change but then randomly stopped working. I would suggest trying to reset your network settings and see if that helps.

When you submitted a ticket, did you try to message a support agent?  If not, you can contact support directly here:

Need Help? Let's chat.