cancel
Showing results for 
Search instead for 
Did you mean: 

Activation Issues - Room for improvement!

volibear
Great Neighbour / Super Voisin

TL;DR - A number of activation issues, but I managed to make it through. I am now a proud Public Mobile member. 

 

Hi All,

 

I'm "New in Town", but that being said I wanted to write down my experience with activation last night in hopes that my comments may help pull some people back from the edge of giving up on Public Mobile. There should be enough keywords in here with what I encountered that Google searches should pick up on this thread as well. Maybe if we're lucky, someone at Public Mobile is reading and will correct some of these issues. 

 

  1. If you get right to the end of the Activation process after putting in your credit card information and receive a "Generic Error", everywhere you go in this forum will tell you to (in one or more of these combinations)
    1. try a different browser
    2. try to clear your cache
    3. try to go into incognito mode

This did not work for me - Generic Error in Chrome Incognito and Generic Error in Edge but you might as well give it a shot. I feel that the root cause is not browser related but more of a synchronization/data problem, but I digress.

 

What might have you worried is that your credit card may show a pending charge (mine did - twice) but if duplicate charges go through a Moderator should be able to help correct this. 

 

@Public Mobile - basic UX/CX should be applied here. Displaying a Generic Error does not help anyone (re: troubleshooting from a tech side and awareness from a user side) and I suspect you're getting dropped subs because of it. Provide a more detailed message or a way for the user to get help. At this point, after receiving it twice I was about to give up. Basing on the number of thread posts relating to "Generic Error" I'm surprised it hasn't been addressed.

 

2. Beyond the regurgitated responses of fuddling with your browser, you may stumble across some suggestions to contact a moderator. 

 

If you're like me (I'm hoping not) you may be scratching your head because how can you contact a moderator when it seems like you need a phone number to sign up for an account? At least that's what I thought and later discovered on my own that I was wrong.

 

Having a community account is different from having a self serve account from what I can tell. In other words the "My Account" > "Create Account" is different from "Community" > "Sign In" > "New User? Register here.". The "Community" account should allow you to contact a Moderator. So go there if you need to contact one. 

 

@Public Mobile - something needs to change to make this more obvious. Either put another section in the "My Account" > "Create Account" that links to the Community Account creation or a link in the automated chat. Anything that isn't buried in the "Sign in" link within "Community". 

 

3. During my attempts I received two other errors - Invalid SIM and something about a session lock and to wait for 50 minutes. The session lock I guess I can understand from a concurrency perspective but the Invalid SIM (which turns out to be a red herring) almost gave me a heart attack. All that to say is that if you hit these, wait the 50 minutes and try again.

 

@Public Mobile - something has to be done about the random Invalid SIM error. Is it really invalid? I can tell you that I'm using my SIM right now even though I received that error. Stay consistent and if it's a session lock then state that instead. 

 

4. I can't speak for ports, but if you're wondering how you can customize your last 4 digits of your phone number, wait until you get to the phone number selection screen and select any number that is presented to you in the list box after you select your city. Once you select any random number a new option to "customize" will appear.

 

This wasn't made entirely obvious during the process and what actually happened was at some point when I was "loading" more numbers into the list box it froze up/timed out. When this happens you'll have to start your application all over again (most likely invoking point #3 above). 

 

@Public Mobile - something is broken with the call to get the pool of numbers to fill in that list box. I think I was able to reproduce it about 3 times on separate occasions where loading a lot of numbers will freeze up the application. This isn't even clicking it like a mad man but waiting a few seconds between clicks. I would say about 15-20 calls is the max I hit before freezing. 

 

5. In my experience if you select a custom number and you get to the end but the application returns with a "Generic Error" (point #1), that custom number will be gone if you try again. It's still OK! This happened to me and I'm not sure if I'm an exception or not but after I was eventually able to sign-up (by picking one of the pre-listed numbers) I was able to get a Moderator to switch my number to the one that was lost because of the "Generic Error".

 

6. Lastly, not to do with activation and with no offence to the way the community is run, but I keep seeing the same responses over and over (e.g. the browser response for "Generic Error") and I'm just curious why something like that isn't either resolved or just a "sticky"? Maybe it is somewhere and I just missed it but seems like free "Bravos" for whomever can copy/paste the same answer the fastest whenever the same question is asked over and over... Anyways, I guess if it's "working" why change it.

 

That said, I'm looking forward to what will come and I hope this post helps at least one frustrated soul out there (like I was last night) to continue pushing through! 😄 

 

7 REPLIES 7

@volibear   Just to clarify that the two names I mentioned to tag in my earlier response (Alan & Catherine) are actually part of PM's management team and not moderators who help resolve account related problems.

@volibear@Alan_K  and PM have been working on a new and improved activation portal. From what I recall it was  in some sort of testing /beta phase. But this seems like forever ago, 6-12  months ago,  not sure the timeline but unfortunately molasis flows quite a bit faster than changes/fixes to the PM systems. 

 

@Alan_K  can you provide any additional info to the new portal?

volibear
Great Neighbour / Super Voisin

@gpixel4 - Unfortunately I stopped playing league awhile ago (but was in it pretty hardcore for years). As I get older, I find it harder to compete and try to keep up with the different meta changes/builds/etc + have a full time job :P. However, I've been keeping up with the pro play. I cheer for TL but their 2020 finals play was no good 😛 Looking forward to Worlds - I really enjoyed the Take Over video that was just released: https://youtu.be/KbNL9ZyB49c.

 

@dabr - thanks for the tips on tagging moderators to take a look at the suggestions.

 

@Jb456 - thanks for the tip on the tags. added a few

 

@RosieR - thanks for the warm welcome!

 

On another note:

1. They really need a multi quote function when replying.

2. I really do appreciate the "load" reply function for replies that are in progress. Clicked on another thing by accident losing my reply but then I was able to load it back up. Very nice!

 

RosieR
Mayor / Maire

@dabr wrote:

@volibear   Great suggestions/observations and I'm sure some of them have been discussed/pointed out before many, many times.  Also absolutely agree about the lack of information about having to create separate Community Account in order to receive help.  That wasn't clear to me either when I signed up just over two years ago.

 

Unfortunately, you'll find changes at PM are slow, if ever.  OTH there's great savings to be had and rewards to be earned and last, but not least, freebie gifts get distributed every now and again! 

 

BTW welcome to PM 😊

 

One other thing you can tag @Alan_K  or @Catherine_T   for your suggestions too and just maybe they may look into one or two things, or maybe not...🙂


^^^^^ this one by @dabr  👍

 

@volibear very good suggestions.  Welcome to Public Mobile and the Community!  Cheers! 😊

Jb456
Mayor / Maire

@volibear  Welcome to Public Mobile.

 

On your post if you look at the bottom you will see "add tags" you can add words, short sentence etc to your post so the search feature will be easier for others searching an the issue.

dabr
Mayor / Maire

@volibear   Great suggestions/observations and I'm sure some of them have been discussed/pointed out before many, many times.  Also absolutely agree about the lack of information about having to create separate Community Account in order to receive help.  That wasn't clear to me either when I signed up just over two years ago.

 

Unfortunately, you'll find changes at PM are slow, if ever.  OTH there's great savings to be had and rewards to be earned and last, but not least, freebie gifts get distributed every now and again! 

 

BTW welcome to PM 😊

 

One other thing you can tag @Alan_K  or @Catherine_T   for your suggestions too and just maybe they may look into one or two things, or maybe not...🙂

gpixel4
Mayor / Maire

@volibear I'll read through your post later lol

This did not work for me - Generic Error in Chrome Incognito and Generic Error in Edge but you might as well give it a shot. I feel that the root cause is not browser related but more of a synchronization/data problem, but I digress

 

you got it. you need to keep the activity going otherwise the system hangs. you need the the special technique called "wiggly mouse"

 

by the way I hate that bear! haha you still play league?