cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
6500K
Model Citizen / Citoyen Modèle

Re: SMS/MMS not working

@Dunkman and @JK8 , I tried my SIM in my previous phone and all SMS/MMS/voice calls worked - both to and from the phone.  My other test phone is provisioned on the Bell Mobility network.

This tells me that the SIM card is working okay and that my Sony XA1 phone may be faulty.

The only thing I can think of that changed is I added the holiday 2GB/500 min intl call add-ons on Wed.  Beyond this, no new apps have been added or uninstalled.

NDesai
Oracle

Re: SMS/MMS not working

@6500K Since everything is working fine on another phone, i do not think there is anything wrong with your sim or account. Issue is within your phone. If you run out of ideas to try, possible solution might be to reset to factory default. 

_________________________________________________________________________
I am not a mod. Do not send me private message with your personal info.
If you need to contact PM, create a Ticket.

New Here? - Check out Knowledge Base Articles to learn more about Public Mobile.

6500K
Model Citizen / Citoyen Modèle

Re: SMS/MMS not working

@benfatto , my apology - I left it to search for several minutes and it did indeed come up with other carriers such as Freedom and Bell.  It tired to connect to them but it failed.  I did notice that Public Mobile has two networks: LTE and 3G.

I'm currently on the LTE network so I'll try to change it to the 3G one and see if it fixes the texting problem.  Keep your fingers crossed.

6500K
Model Citizen / Citoyen Modèle

Re: SMS/MMS not working

@NDesai ugh the dreaded factory reset - thanks for the suggestion but I was trying to avoid even mentioning it hahaha

I have too many customizations on this phone to do that now.  My immediate solution may be to use my old phone until I can really dig into this and separate out the culprit.

 

I really do appreciate all the input so far from everyone.  This is why I think PM is #1 in community help!  🙂

darlicious
Mayor / Maire

Re: SMS/MMS not working

@6500K 

I know you checked the message centre number but did you follow thru?

 

Program the SMS service centre number

If you are not able to send text and picture messages, make sure that the correct SMS service center number is set up on your smartphone.

From the Home screen, tap Phone.

Dial *#*#4636#*#*

Select Phone Information.

Make sure the following number is entered in the SMSC box: +16475800172.

Tap Update.

The SMS service center number is set up on your smartphone.

Restart your smartphone

Restarting your smartphone causes its software to reload and renews your connection to the network, which can fix some problems:

Remove the battery.

Wait ten seconds.

Reinsert the battery.

Turn your smartphone on.

Your smartphone is restarted.

Tags (1)
6500K
Model Citizen / Citoyen Modèle

Re: SMS/MMS not working

@darlicious Thanks for the further instructions. I tried the "Update" button and rebooting it and it still does not send/receive SMS/MMS messages.

Unfortunately, my phone has an unremovable battery so I cannot do the latter half of your instructions.

6500K
Model Citizen / Citoyen Modèle

Re: SMS/MMS not working

Here's the weird thing.  I tried what @benfatto suggested and switched from PM's LTE to 3G and it took.  Then I was able to send an SMS and an MMS to my other Bell phone.  Then I sent an SMS and an MMS to my PM phone (Sony XA1) and it all worked.

I thought I was golden, until I tried it a few minutes later and it was back to the problem again.

 

I have not been able to reproduce this.  Like I said earlier, I may have to use my old phone until I can try some new suggestions.  In the end, if it ends up that it's my XA1 phone then I'll have to look for another to replace it.  I'll keep everyone posted.

 

Thank you all for your help so far.

6500K
Model Citizen / Citoyen Modèle

Re: SMS/MMS not working

Just one more piece of the puzzle:

I looked at the service menu and phone info area.  The sub menu on IMS status says my IMS is unregistered.  I contacted the moderators and listed this as a possible reason for my problem.  Hopefully, they will be able to offer a fix.

 

Btw, I have been with PM for over almost 3 years with this same phone.  Never had any problems until now.  Baffling eh . . .

Dunkman
Oracle

Re: SMS/MMS not working


@6500K wrote:

Just one more piece of the puzzle:

I looked at the service menu and phone info area.  The sub menu on IMS status says my IMS is unregistered.  I contacted the moderators and listed this as a possible reason for my problem.  Hopefully, they will be able to offer a fix.

 

Btw, I have been with PM for over almost 3 years with this same phone.  Never had any problems until now.  Baffling eh . . .


@6500K 

See what the moderator says.  

 

As mentioned before, you could eventually try

network reset

factory reset (last resort).

JK8
Mayor / Maire

Re: SMS/MMS not working

@6500K 

 

Can you download another texting app and see if it works.

Need Help? Let's chat.