Showing results for 
Search instead for 
Did you mean: 

lost phone. tried all the steps in the last two weeks. no way to get into my account.

Great Neighbour / Super Voisin
I have made this throwaway account to try and access my actual real life, used, long time customer account with public mobile.
over the last couple weeks I have tried unsuccessfully to login, it goes like this..
login details, cool, security, 6 number thing pops up (ever safe?), it sends the code to my phone - which I don't have, it lost in a snowbank, in purgatory now. now, the  only options available to me after that when i try to log into my account are to try again by text message (to my lost phone) or a voicemail (to my lost phone, doomed in purgatory), neither of those I can do as I DO NOT have my phone.
Yes, I have tried dialing my own number and accessing my voicemail through another phone, then entering a password, but voicemail is locked too..
I need to get into my account to get another sim, cancel my credit card details and report phone lost/stolen though cannot due to the login requirements.
TO REPEAT. There is no send email prompt. Only text and voicemail/fail.
'help' topics phone number and email I've used with 0% success rate. 
1-855-478-2542 - robot automation, no options for any assistance on there either. - random email - apparently this is not moderated. 
I can't escape from the Public Mobile Ever Safe prison, I'm paying $$$/real, actual money to public (TELUS) for a service, but where is it, i cant find it!?

Great Neighbour / Super Voisin

@hairbag1 @softech ok thanks folks got it sorted, i did the reset thing work around and ordered a new sim card.

thx for the help.

Mayor / Maire


use this link to message Customer Support....

provide as much info as you; phone #, name on acct, PM pin #..etc



quickest way is to ask support to help

**Monitor your Community inbox (envelope icon on top right) after the ticket is opened.  CS Agent will reply to you there

if you want to give "send email" option another chance, try these workarounds:

  1. Reset your password to self service account. Once reset, sign in again with new password. Might be able to receive 2FA via email instead to gain access.
    (!!!You will need to click Resend Code and then Send email to trigger the 2FA to email)
  2. Potential workaround (for some): If you don't have access to SMS OTP, try entering an incorrect OTP code 4 times. For some individuals, this is giving the option of an email instead.
Need Help? Let's chat.