Showing results for 
Search instead for 
Did you mean: 

Unable to create Self serve account to activate account online

Good Citizen / Bon Citoyen
  • I get : SIM card number incorrect (it’s not)

Username already used. I used my email address (which is very perculiar). Tried unsuccesfully to submit account creation form. Kept getting « Problem submitting form ».

so can’t create account.

Ttried 30-40 times to submit account creation form. Never got username already used.

Kept getting « Désolé, nous éprouvons des difficultés avec le traitement de cette demande. ». Which more or less means : Unable to process your request ».

I think account is partially created because username has registered. But cannot login with it.

This morning, 8 hours later : cannot login to self serve account with email address. I get : Sorry, your login attempt failed. Please try again.

when i try to resubmit account creation form, i get that username (email address) already used and SIM number is incorrect (it is not).

Also, can’t open ticket because i need proof of account info which is not opened!


Getting nowhere fast


very frustrated




Great Neighbour / Super Voisin

I had a similar problem activating my daughters SIM on a iPhone to Public Mobile, I tried both her and my iphones and kept getting a message.  I was close to giving up, but went to my laptop and activated it from the laptop with no issue. 

Good Citizen / Bon Citoyen

Thank you Leanne.

Tried from PC a few minutes ago.

Can't resubmit form PC because system says my phone number is already used (probably by me !!!).

Tried to sign in with info i submitted on thusday. Does not work.

Tried submitting form for "forgotten password". System does not recognize my email address.

Going in circles.

Thanx again.

Good Citizen / Bon Citoyen

Tried, still does not work.

Good Citizen / Bon Citoyen

No, don't have Koodo account. Have a Bell account.

If system tells me username (email address) is already used, should i not be able to submit a "Forgotten password" request form to that address ? Keep getting that they can not verify address when i submit to "forgonne password".

Hello @Djaoune ,


Sorry to hear you are having so much trouble. I would say to contact the moderators at this point for some assistance.


BEFORE YOU do though...enter your email  here  (that is if you did not activate successfully yet) as there is a current promotion to get your 2nd 30-day cycle FREE. 🙂


See terms and conditions here:



To contact the Public Mobile Moderator_Team, there are two ways to reach them:

1 -  Click the bubble comment circle on the bottom right hand side of your screen to talk to SIMon the chat bot or link:


2 - Contact the Moderator_Team via private message using this link:

Good Citizen / Bon Citoyen

Hi there,


I’ve seen on other similar posts people say you can clear your browser history and then try again in incognito mode to see if you can enter into the account. If not try a completely different browser eg. if you’re trying on your phone try on a computer using chrome or internet explorer. If none of that works, you may need to contact a moderator to confirm whether the account is actually made or not, as that seems to be the biggest unknown here. Did you get through to typing in security questions when making the account? If so you should be able to access and reset password through moderators to then try activate once you have access

Good Citizen / Bon Citoyen

Incognito mode worked


Big thank you

Great Citizen / Super Citoyen

good , you got going I got the same issue and now waiting for an hour on my wifes phone account.

I complete to the phone# porting  and submitted and everything died on public side, everything became frozen.  logged out and back with a different browser. Now it says my sim is invalid on first page.

Good Citizen / Bon Citoyen

Was able to complete account creation after using incognito mode with google.

Hope that works for you.

Great Citizen / Super Citoyen

Its becoming comical. When using incognito mode, Web page says my sim is tied up in another session try again in 50 minutes. Tried again after 1 hour and same thing wait 50 minutes so waiting agian now again.