Showing results for 
Search instead for 
Did you mean: 

SMS not working since system change

Great Neighbour / Super Voisin

Hi All, I have a 2 yr old OnePlus Nord N20. The MMS stopped working with the recent change. I've made the manual updates as shown:

MMS Proxy:
MMS Port: 8799
MCC: 302
MNC: 220

When I made these changes, it worked fine for a while. But the next morning there was no longer any connection. I see "emergency calls only". If I reset the SIM, or toggle airplane mode, it works again, but only temporarily.  So now I get no MMS and  SMS service only works for an hour.

I can live without MMS, but not with this. Any help appreciated



Great Neighbour / Super Voisin

Hello,  I just had a colleague with the same model of phone and issue. Here's what I found. Sorry to necro this thread, I just found it via google and thought I could provide a bit more context. 

They had 2 APN's configured. One for public mobile which was correct, and one for some sort of tether or something. So I deleted both of them and then a THIRD ghost APN showed up suddenly unexpectedly for telus. 

So I deleted that one too until there were none. Entered in the public mobile one someone already provided in this thread. Rebooted, then everything started working.

I'm an I.T person by trade, not a phone person but here's my perspective of what might be happening in this situation.  The sim public mobile gives people has the APN configured in most cases these days but the android os likely hung onto to that third old telus one. Voicemail and mms messages were likely being tried through that hidden APN instead of using the sim APN's and the fact that there's a bug where the OS will hang onto the old APN without showing it on the screen makes this tougher to troubleshoot.  Maybe the first APN's server has to go down for maintenance or something before it stops trying that ghost APN and tries the next one which would explain why it is sort of intermittent. 

Anyway, hope this helps anyone else googling in the future.

Have a nice day.

Great Neighbour / Super Voisin

Has worked for 4 weeks but yesterday MMS stopped working. Tried re-doing the settings but still does not work. Did something else in public mobile system change? Anyone else having similar problem?

Great Neighbour / Super Voisin

I was unable to send to any iphone device.  your solution of using all caps for the APN fixed my issue Thank you so much!

My settings are below.
MMS Proxy:
MMS port:  8799
MCC:  302
MNC:  220
APN type:  default,mms,supl
APN Protocol:  IPv4/IPv6
APN roaming protocol: IPv4


Great Neighbour / Super Voisin

When I put the APN part into caps, it worked (SMS and MMS) for a day, then I had to restart to get it working. This happened a couple times. It has now been working for about a week without issue.  

Great Neighbour / Super Voisin

I have a N200 5g and I am having the same issue.  I want to say it happened on the 28th or 29th.  I have deleted the apn's, created them new, reset the apn's and modified the one that was created.  I have tried using the old apn on 3g.  
I am unable to send pics or receive them.  

I realize this isn't much help, but there seem to be a bunch of us out there that are having the same issue.  

Mayor / Maire

HI @keen227 

some OnePlus user have to do this, delete the current APN and the Add a new one again by reentering everything.  Remember to save and reboot 

Need Help? Let's chat.