Showing results for 
Search instead for 
Did you mean: 

My account

Great Neighbour / Super Voisin

Anyone else having issues getting into My Account?


I get this when I click on My Account or Sign In tab.



Great Citizen / Super Citoyen

I often have problems signing in. It seems if I  don't sign in often enough, my account is at a stand still and I have to jump through all kids of hoop just to request info. I guess they want you to just check in every now and then, don't know the reasoning for that, but I find it annoying



Both My Accounts and My Rewards are up and runnig again now, but loading slower than usual


If you have issue, try to login using Incognito mode.  If you are not in a big rush, wait till tomorrow morning to login 

@Williamlu1166   it is actually a problem on Telus side (PM hosting its My Account/My Rewards on Telus server) and affecting Telus and Koodo's My Account as well.



Good Citizen / Bon Citoyen

Still Error.

Deputy Mayor / Adjoint au Maire

Still down. 

Great Neighbour / Super Voisin

I get the same error message (although with a different reference number each time). I’ve tried repeatedly over the past hour. Any ETA on a fix to the site?

@HavocDragon  with My Account down, you cannot even test now  😞


Reply the same message and let them now

When the page is up again, test with Incognito mode.  Or test on a desktop with all the extension disabled.  For chrome on windows, this is how it can be done


"C:\Program Files\Google\Chrome\Application\chrome.exe" --disable-extensions


"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-extensions

Great Neighbour / Super Voisin

Softtech I already did and as I said they changed my password to a temporary but that did nothing 😔

@HavocDragon   for the moment, please message support to open ticket :

**Monitor your Community inbox (envelope icon on the top right) after the ticket is opened.  CS Agent will reply to you there




Great Neighbour / Super Voisin

I sent in a ticket and for some reason they rest my password that I didn't need reset.. and still can't click on it 🤦

Mayor / Maire

HI @HavocDragon   


I can confirm I have the same issue


@HavocDragon   Me too  😞  Unexpected


Let's hope it will be back soon

Need Help? Let's chat.