cancel
Showing results for 
Search instead for 
Did you mean: 

Call display issue

zlq0000
Great Neighbour / Super Voisin

Hi there,

I am new to PM. My phone is Samsung Galaxy A5 which is unlocked from Fido. Now I inserted the PM sim card. The call display doesn't work. All the income calls shown as "Private number". Anyone has a solution?

thanks,

 

 

 

9 REPLIES 9

srlawren
Retired Oracle / Oracle Retraité

 


@computergeek541 wrote:


All Fido phones that are unlocked and are compatible with the Fido 3g network are also atuomatically compatible with the Public Mobile network.  It's the same type of network and running on the same type of 3g/UMTS frequencies.


 

Note that there is a small caveat in @computergeek541's comment here, which I bolded in the quote above.  While this is obviously not a factor for @zlq0000's situation, not every phone that works on Fido (or Rogers or Chatr) will work with Public Mobile (or Koodo, Telus, Lucky, Virgin, or Bell) since Rogers still operates (until Dec 31 2020) a 2G GSM network.  So really the statement should be more like "All Fido phones purchased in Canada within the past several years and are unlocked....".


>>> ALERT: I am not a moderator. For account or activation assistance, please click here.


@CS_Agent wrote:

Hi zlq0000,

 

Thank you so much for getting in touch with us today.

 

You can check on the Public Mobile website if your phone is compatible with our network ( https://www.publicmobile.ca/en/bc/get-started ) at "Check your phone's compatibility" section since there are multiple models of Samsung Galaxy A5.

 

Regards,

Ciprian

PM Mod Team.


All Fido phones that are unlocked and are compatible with the Fido 3g network are also automatically compatible with the Public Mobile network.  It's the same type of network and running on the same type of 3g/UMTS frequencies.

 

Keeping that in mind, @zlq0000 has already informed us that the phone is compatible, and we know the becuase if the phone weren't compatible, phone calls wouldn't even be working in the first place.

zlq0000
Great Neighbour / Super Voisin

Thanks everybody.

 

 I use my home phone and another cell phone call the PM phone, the issue is there. I switch the SIM card with another cell phone back and forth, then the income calls displayed. 

JC29
Great Citizen / Super Citoyen

That "Private Number" that you see if a network provided number block.  Normally, that is the service provided by the network of the person calling you.  But in your case, you have said that ALL numbers have that?  Then this might be a problem for the MODS as PM might have to turn something on in your account


@zlq0000 wrote:

Hi there,

I am new to PM. My phone is Samsung Galaxy A5 which is unlocked from Fido. Now I inserted the PM sim card. The call display doesn't work. All the income calls shown as "Private number". Anyone has a solution?

thanks,

 

 

 


 

delilap04
Good Citizen / Bon Citoyen

Contact PM and ask them to enable calls to be seen on your screen. Only they can do this.

dabr
Mayor / Maire

@zlq0000 wrote:

Hi there,

I am new to PM. My phone is Samsung Galaxy A5 which is unlocked from Fido. Now I inserted the PM sim card. The call display doesn't work. All the income calls shown as "Private number". Anyone has a solution?

thanks,

 

 

 


The only time that normally happens is someone has blocked their number from being displayed.   Is this happening to all incoming calls?  

 

Did the earlier suggestion of rebooting fix this problem?

 

 

@Ciprian_C your reply did not answer the question.

 

The phone is obviously compatible and working. Caller ID is not working. Please read it again.

CS_Agent
Customer Support Agent

Hi zlq0000,

 

Thank you so much for getting in touch with us today.

 

You can check on the Public Mobile website if your phone is compatible with our network ( https://www.publicmobile.ca/en/bc/get-started ) at "Check your phone's compatibility" section since there are multiple models of Samsung Galaxy A5.

 

Regards,

Ciprian

PM Mod Team.

GR
Mayor / Maire

@zlq0000 did you try restarting your phone to start