cancel
Showing results for 
Search instead for 
Did you mean: 

Autopay Not Working

ReallyPissedOff
Good Citizen / Bon Citoyen

I've used the same RBC Visa Debit to pay for my service on Autopay for more than 3 years and now all of sudden the funds didn't draw this month.

The card is valid and there's sufficient funds in the account, is anyone else having these issues?

17 REPLIES 17

softech
Mayor / Maire

@ReallyPissedOff   

 

You login to My Account and confirmed that the account status is Suspended?

 

Autopay fails sometimes for no reason

 

Try to do a manual pay and see how it goes.  Login to My Account, Payment Tab, One time Payment

E-Paymt-AmtDue_Other.png

 

First select Amount Due and see if payment goes thought

If not, then try again with "Other" and enter the plan amount +$1 extra

 

once payment goes through, click on "Reactivate current plan" if it is there

Then logoff My Account and reboot your phone

pkaraa
Deputy Mayor / Adjoint au Maire

@ReallyPissedOff is anything changed since it was charged last time.

 

New card with new expiry date and new CVV...

 

New address may be?

Click on Manage my card in 'my account' and try to remove the card and add it again. Meantime if your account have got suspended then pay with a voucher to get your plan back.

 

 

Taheshia
Great Neighbour / Super Voisin
 

Taheshia
Great Neighbour / Super Voisin

I am having this issue as well.

pkaraa
Deputy Mayor / Adjoint au Maire

@Taheshia you also follow the same route and let us know if that works for you.

Taheshia
Great Neighbour / Super Voisin

That route did not work for me. I have the balance in my account and cannot access autopay. 

esjliv
Mayor / Maire

@ReallyPissedOff wrote:

I've used the same RBC Visa Debit to pay for my service on Autopay for more than 3 years and now all of sudden the funds didn't draw this month.

The card is valid and there's sufficient funds in the account, is anyone else having these issues?


@ReallyPissedOff  - your user name makes me tense, and I want to take a deep breath.

 

Do you know your Autopay is not working because you LOST services on your phone?

If you have no services, and it is past your renewal, your autopay likely failed.

  1. Add Funds to your Plan Amount through SELF SERVE (or by calling 611 if you have a card registered)
  2. Go to “Plan and Add-Ons” TAB
  3. Select "Lost/Stolen Phone" TAB
  4. Select "Suspend Service" BUTTON
  5. Then, Select Resume/Reactivate Service
  6. Reboot your phone.

If this was an Autopay failure, I would let the Customer Support Agents (CSA) know.

 

Methods to contact the Customer Support Agents (CSA): https://www.publicmobile.ca/en/bc/get-help/articles/contact-a-moderator

 

 

 

If you still have services, this could be your account going through the normal renewal process. The SELF SERVE account can say "expired" or "suspended" on the day of or before your plan is due to renew.

So, if this is the case, ignore these messages on your SELF SERVE account.

HALIMACS
Mayor / Maire

@ReallyPissedOff   @Taheshia 

 

Had you viewed this earlier?  ....   however now is it no longer there?

 

HALIMACS_0-1640867565133.png

HALIMACS_1-1640867584604.png

 

 

Much ado about nothing, except poor messaging by Public Mobile on the eve of a normal renewal cycle.

ReallyPissedOff
Good Citizen / Bon Citoyen

Nothing has changed, see my original post.