cancel
Showing results for 
Search instead for 
Did you mean: 

Android 8.1.0 APN settings

frankindustries
Good Citizen / Bon Citoyen

I have an Asus Zenphone 4 with Android 8.1.0 and I am attempting to get my data package working and everything I have read has said that I need to change my APN settings to the PM specific settings but when I attempt to do that I am unable to add or edit any APN settings. ( they are greyed out)  

 

So I did some reading on this issue and apparently most phones running Android 8.1.0 are unable to edit the APN settings. There was a solution offered that involved rooted your phone (whatever that is) or running something called an ADB shell ( also what the hell is that) Needless to say I am not comfortable with either of those options and am hoping that there might be a more current solution ? 

16 REPLIES 16


@sandpublic wrote:

@z10user4 wrote:

@sandpublic wrote:

My intentions were not to take credit or hide the fact that it was a copy or paste. I was just trying to help the original poster and since the original links were  included I tought it was ok.  @frankindustries  I apologize for any inconveniece and next time I will  just include the entire link so not to offend anyone.


Very nice. It's actually more towards flattering for the original writer I think. I have copied useful "boilerplate" text before too...but then I massage it a little to something of the way I might say it. I have seen my text re-appear on the rare occassion too. Doesn't bother me. It probably doesn't bother wetcoaster too. It was just surprising recognition on their part.


Got it. Thanks for letting me know, I will make sure I do the same in future posts.


Any Joe can drive a Geo Metro in the sand. It's just a messy game to not at least change it up from the original.

sandpublic
Town Hero / Héro de la Ville

@z10user4 wrote:

@sandpublic wrote:

@z10user4 wrote:

@sandpublic wrote:

My intentions were not to take credit or hide the fact that it was a copy or paste. I was just trying to help the original poster and since the original links were  included I tought it was ok.  @frankindustries  I apologize for any inconveniece and next time I will  just include the entire link so not to offend anyone.


Very nice. It's actually more towards flattering for the original writer I think. I have copied useful "boilerplate" text before too...but then I massage it a little to something of the way I might say it. I have seen my text re-appear on the rare occassion too. Doesn't bother me. It probably doesn't bother wetcoaster too. It was just surprising recognition on their part.


Got it. Thanks for letting me know, I will make sure I do the same in future posts.


Any Joe can drive a Geo Metro in the sand. It's just a messy game to not at least change it up from the original.


??? Please explain


@sandpublic wrote:

@z10user4 wrote:

@sandpublic wrote:

@z10user4 wrote:

@sandpublic wrote:

My intentions were not to take credit or hide the fact that it was a copy or paste. I was just trying to help the original poster and since the original links were  included I tought it was ok.  @frankindustries  I apologize for any inconveniece and next time I will  just include the entire link so not to offend anyone.


Very nice. It's actually more towards flattering for the original writer I think. I have copied useful "boilerplate" text before too...but then I massage it a little to something of the way I might say it. I have seen my text re-appear on the rare occassion too. Doesn't bother me. It probably doesn't bother wetcoaster too. It was just surprising recognition on their part.


Got it. Thanks for letting me know, I will make sure I do the same in future posts.


Any Joe can drive a Geo Metro in the sand. It's just a messy game to not at least change it up from the original.


??? Please explain


I have a little Metro. Gets a zillion miles per imperial gallon. I was just continuing on with the thing about copying others text using some text that almost certainly won't be copied :).

sandpublic
Town Hero / Héro de la Ville

@frankindustries wrote:

I have an Asus Zenphone 4 with Android 8.1.0 and I am attempting to get my data package working and everything I have read has said that I need to change my APN settings to the PM specific settings but when I attempt to do that I am unable to add or edit any APN settings. ( they are greyed out)  

 

So I did some reading on this issue and apparently most phones running Android 8.1.0 are unable to edit the APN settings. There was a solution offered that involved rooted your phone (whatever that is) or running something called an ADB shell ( also what the hell is that) Needless to say I am not comfortable with either of those options and am hoping that there might be a more current solution ? 


More info can be found here:

 

https://productioncommunity.publicmobile.ca/t5/Phones-Hardware/Android-8-1-APN-settings/m-p/241715#M...

Alex888
Mayor / Maire

@frankindustriesPart of the problem is likely your phone, if you look on https://willmyphonework.net/ the phone you have is not very compatible with Public Mobile, you may be able to get a connection to 3G in some areas, depending on where you live, but most of PM data is throttled 4 LTE, which your phone does not support.

hycm53
Town Hero / Héro de la Ville

@frankindustries Looks like some link is no longer existed for MyNewAPN_test.apk

You can Googl this app. If you can't find it, you can pm me, I will sent this app to you, since the PM community doesn't allow upload app. 

My cell is Asus Zonfone 4 Max and the app is working for me.

But again You will take your own risk, I am not responsibility for any damage for your phone.

 

humon
Great Neighbour / Super Voisin

Whomever of you folks came up with all or part of the solution - thanks.

I had the APN problem on an Asus Zenfone4Max running Android 8.x & following logic included in these posts was able to use ADB on my Linux system directly.

I thought I had to download the full Android Studio to fix it, but not.

I entered developer mode on the phone, ran ADB and wrote a new APN, saved it, restarted and problem solved.

 

Thanks community.