cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

MMS Won't Work, Tried Everything

Hey,

I got a new phone, HUAWEI P30 Lite.  I did everything on the forum such as adding a new APN and writing exactly what you guys recommend.  I restarted the phone, I still can't send or receive mms messages.  I even did a reset for my network settings, restarted phone and readded the APN.  

 

I tried to send mms messages, it won't send. I tried receiving mms messages, it won't receive.  I tried enabling wifi, then switching to mobile data only...and still nothing.  If I browse the internet, wifi works and so does mobile data.  But MMS....zero luck! Please help.

Highlighted
Mayor / Maire

Re: MMS Won't Work, Tried Everything

 @blessme4k 

Try adding ,mms to the APN Type line. That's a comma with no spaces anywhere.

Highlighted
Good Citizen / Bon Citoyen

Re: MMS Won't Work, Tried Everything

@z10user4 


"You do not have permission from your carrier to add -Type APNs"

This is when i write " ,mms "

 

When I simply write "mms", it allows me. But when i restart, i still can't send or receive mms.

Highlighted
Mayor / Maire

Re: MMS Won't Work, Tried Everything


@blessme4k wrote:

@z10user4 


"You do not have permission from your carrier to add -Type APNs"

This is when i write " ,mms "

 

When I simply write "mms", it allows me. But when i restart, i still can't send or receive mms.


I've not heard of that message before. But I don't know everything 🙂

You'll need default and mms and likely some others.

Maybe post screen shots of your APN settings.

Highlighted
Good Citizen / Bon Citoyen

Re: MMS Won't Work, Tried Everything

Tried this just now:

http://prntscr.com/uh5ev4

 

I even tried it where I left the APN type blank or just mms. I also tried it with MVNO type as blank also.

 

Nothing...

 

Tried this also:

Highlighted
Mayor / Maire

Re: MMS Won't Work, Tried Everything

 @blessme4k 

There are some subtle variations here and there.

I would still be focussing on APN Type.

But there's also

MMS proxy: mmscproxy.mobility.ca

MMS Port: 8799

 

My APN Type is default,mms,supl.

I've read here of blank MVNO fields too but I have GID and 4D in mine.

Highlighted
Good Citizen / Bon Citoyen

Re: MMS Won't Work, Tried Everything

I've tried the first one too, that was my default settings originally. Still nothing.

Highlighted
Mayor / Maire

Re: MMS Won't Work, Tried Everything


@blessme4k wrote:

I've tried the first one too, that was my default settings originally. Still nothing.


hmm. Any chance for seeing those screen shots? Pictures tell a thousand words.

Your cell data is on right? It needs to be on to send/receive MMS. Or a toggle that would do it automatically.

Highlighted
Good Citizen / Bon Citoyen

Re: MMS Won't Work, Tried Everything

IMG_20200914_125907.jpgIMG_20200914_130025.jpgIMG_20200914_125856.jpgI took a screenshot of three different settings:

 

https://prnt.sc/uh5r7n

Highlighted
Mayor / Maire

Re: MMS Won't Work, Tried Everything


@blessme4k wrote:

I took a screenshot of three different settings:

 

https://prnt.sc/uh5r7n


I see nothing off with the first two. The right one doesn't have APN Type but you were probably testing that.

What do you have for those MVNO values?

Your phone can take it's own screen shots. But your method worked. 🙂