cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Good Citizen / Bon Citoyen

Autopay charge not applying to account even though it was removed from my bank

This morning i got a text saying that my account needed a manual payment to top up, i assumed that autopay broke somehow. so i manually went in to the self serve portal and noticed a balance of $0 so made a payment and selected to pay the Amount Due of 40$. however after this, i noticed that my bank already had a charge from public mobile for my monthly fee on the 30th of august. I looked into the transaction history and saw that i was charged at the end of august for the 30 day plan and my 5gb/3g. unless i am not understanding how monthly payments work it appears that i was charged twice this month for the 30 day plan?

 

is there any way to either get my money back or put the money towards next month?

 

Public mobile transaction history:Annotation 2019-09-10 101430.jpg

 

Screenshot of my online bank statement:

 

Annotation 2019-09-10 101608.jpg

 

Deputy Mayor / Adjoint au Maire

Re: Autopay charge not applying to account even though it was removed from my bank


@nayrboh wrote:

This morning i got a text saying that my account needed a manual payment to top up, i assumed that autopay broke somehow. so i manually went in to the self serve portal and noticed a balance of $0 so made a payment and selected to pay the Amount Due of 40$. however after this, i noticed that my bank already had a charge from public mobile for my monthly fee on the 30th of august. I looked into the transaction history and saw that i was charged at the end of august for the 30 day plan and my 5gb/3g. unless i am not understanding how monthly payments work it appears that i was charged twice this month for the 30 day plan?

 

is there any way to either get my money back or put the money towards next month?

 

Public mobile transaction history:Annotation 2019-09-10 101430.jpg

 

Screenshot of my online bank statement:

 

Annotation 2019-09-10 101608.jpg

 


There seems to be a problem with your account. You should be charged only once every 30 days.

 

You need to contact moderator_team. Click on the green bubble on bottom right to get started.

Great Citizen / Super Citoyen

Re: Autopay charge not applying to account even though it was removed from my bank

If you look into your account, you should have what you manually paid for in there. It will go towards your next renewal. If you really need a refund you'll need to message the mods to complete it. Be aware that there is quite a wait currently as I'm going on 4 days for my own issues I've messaged them about

Oracle

Re: Autopay charge not applying to account even though it was removed from my bank

It seems like a renewal bug has hit the system.  I just posted a response to another account that exhibited the same behavior.  If the service has actually been interrupted, you need to seek moderator team assistance.  The moderator team can be reached via private message using using smartforms which is initiated by clicking on the ? on the lower right corner of the webpage. The guided process will facilitate documentation of the issue or concern and the required resolution which will be submitted to the moderator team.  Refer to this announcement link for additional details on smartforms and the ticketing system for moderator team interactions.  Refer to the following knowledge base article for additional information on the moderator team.

 

 

 

 

 

 

Good Citizen / Bon Citoyen

Re: Autopay charge not applying to account even though it was removed from my bank

Thanks! i figured id have to contact them... well i sent a pm and we'll see where this goes...

Deputy Mayor / Adjoint au Maire

Re: Autopay charge not applying to account even though it was removed from my bank


@nayrboh wrote:

Thanks! i figured id have to contact them... well i sent a pm and we'll see where this goes...


Meanwhile, if your phone is working, great!

 

If service was indeed cut-off, try to pay the "balance owing" to have your service restored.

Once Moderator_team will get back to you, request a refund for any extra payments you made, any amount you overpaid will be credited to your account (so you won't have to pay again next month).

Good Citizen / Bon Citoyen

Re: Autopay charge not applying to account even though it was removed from my bank

my service is working for now... but i paid for it twice lol

Deputy Mayor / Adjoint au Maire

Re: Autopay charge not applying to account even though it was removed from my bank


@nayrboh wrote:

my service is working for now... but i paid for it twice lol


Good to know. I took another look at your payment history.

 

Is it possible you manually topped-up on Sept 10?
And you also requested an immediate plan change to the $10 plan?

 

When you look at your Oveview page, which plan do you have now?

Good Citizen / Bon Citoyen

Re: Autopay charge not applying to account even though it was removed from my bank

as is said in the op after i got the text i manually topped up my account to the 40 i normally get charged, however each month after i top up my account public removes 10$ for the 30 day plan and a seperate 30$ for the 5gb/3g plan, idk why they do it this way, kinda confusing. but for some reason after i was charged the 10$ and the end of august i was also charged 10 today when i manually added funds. waiting on a mod's reply, hopefully get this fixed as i dont have an excess of cash rn

Deputy Mayor / Adjoint au Maire

Re: Autopay charge not applying to account even though it was removed from my bank

You are right. Moderator will be able to help you sort through your plan.
PM charged you $10 on Sept 10, which should be refunded to you.