cancel
Showing results for 
Search instead for 
Did you mean: 

You are not subscribed to a mobile data service

mbm5
Great Neighbour / Super Voisin

I am trying to set up my data.  I am using an iPhone 5s, bought initially in the UK and used on the Vodafone network there.  It is supposed to be unlocked.  

Calls are working, but data is not.  On either trying to access web pages or updating emails, I get a message that "You are not subscribed to a mobile data service".

 

I have followed all advice on this post:

 

https://productioncommunity.publicmobile.ca/t5/Getting-Started/Iphone-6-no-MMSC-OR-MMS-Proxy-under-c...

 

except for the final step.  I have tried to update using iTunes, but it says that I am currently using the most up-to-date version of iOS (I actually updated earlier today).  Is it possible that the appropriate carrier information for Public Mobile is not in my OS, despite the update, and if so, how to I update either just this or force an update of iOS?  Whether the issue is likely to be this, or something else, any and all suggestions would be greatly appreciated!

 

One thought - if the phone was not unlocked, would this affect only the data, or would it affect the calling as well?  Or in other words, does the fact I can make calls confirm that my phone is indeed properly unlocked?

 

Thanks,

 

Michael

5 REPLIES 5

mbm5
Great Neighbour / Super Voisin

Thanks - it seems to work!

mbm5
Great Neighbour / Super Voisin

Thanks - there was a Vodafone profile of some sort (also an eduroam one which hopefully isn't the issue), I just deleted the Vodafone one for now, and am restarting....

mbm5
Great Neighbour / Super Voisin

Hi,

 

I just tried sending a text, and the progress bar across the top got almost all the way across, and then seems stalled.  It doesn't say either "Delivered" or "Not Delivered" (yet, at least).

 

I'm sorry I don't know the difference between MMS and SMS texts.  But under Settings > Messages, it seemed MMS was on and SMS was not.  I turned the SMS toggle on.  This doesn't seem to be helping my message to send.

 

When I go to Settings > Mobile Data > Mobile Data Network (I think these are the equivalent places to the instructions, but using UK wordings), there is an APN (it is currently at isp.mb.com - I've changed it back and forth from this to sp.mb.com with no luck; it gets changed back to isp.mb.com whoever I try the re-set suggested in the post I originally referenced).

 

However, there is little else.  There is "Username" (blank) and "Password" (blank), and a an option to "Reset Settings".  None of the other things in the instructions you send (i.e., no MMSC, MMS Proxy, etc).

 

Michael

iliketotalk
Mayor / Maire

@mbm5 hi can you try going to the settings of your phone and then general-profile and make sure that there is no existing profile, if there is a profile then please delete it. 

gblackma
Mayor / Maire

It's unlocked, or the PM SIM wouldn't work @mbm5.   Is your text working ? Can you send sms and mms texts. Thanks. If not, enable sms and mms messages and try again. Thanks. Here's a link on the correct APN settings. https://apn-canada.gishan.net/en/apn/public-mobile/apple-iphone-5 . Please compare them to yours and change as needed, save and restart . Welcome to PM.  Stay safe. 

If this doesn't work let us know. Thanks.

What plan are you on? And are you using autopay. Thanks.