Showing results for 
Search instead for 
Did you mean: 

Website bugs preventing my dad from signing up

Great Neighbour / Super Voisin

I've been trying to sign my dad up to Public mobile but this website has been putting up every roadblock imaginable and I'm not sure what to do.

I told my father about public last month and he attempted to sign up but mistakenly selected "eSIM" without understanding what it was and activation didn't work. I'm still not sure the reason. Incompatibility? Website glitch? Did he need to remove Bell sim? Whatever the case, it just led to an error message and gave no way to go back and select the physical SIM. His phone is a Galaxy A11 btw.
*We also couldn't use the app because it doesn't recognize his email as valid yet.

This month we decide to try again and sign in. It gives us the option to "resume activation" but when we click on it, it makes us sign in again and this time it says our passwords do not match (we used the exact same password as before so it's not a typo). My dad has no way to even interact with the site past this point.

I've been looking for someone to talk to but public doesn't seem to have a customer service line and when I try making a ticket, I get an error message every time. I can't even go to the ticket screen without an error now. I then tried messaging the CS_Agent but when I try to send, it says there's "invalid HTML" and never works.

I don't know what else to try at this point. Is there any real person I can contact to help with this? Never has a website put up this many hurdles to prevent us from giving them money.


*Edit: I was finally able to PM an agent but their instructions were kinda complicated and my dad got tired at that point and just went with a different service 💀
Welp... So much for my Refer-a-Friend bonus. Oh well.


Great Neighbour / Super Voisin

I don't see how I can get the app to work on his phone if they still don't recognize his email. I did finally manage to get a PM sent to an agent though so hopefully that'll help. I really wish they had a phone number though.
If this takes too long my dad might give up and look for a different service 💀
Anyway thanks for the response.

Great Neighbour / Super Voisin

Thanks for the response! I don't think it involved copy and pasting but I tried sending another PM after reading this and it finally worked this time. Hopefully something comes of it.

Great Neighbour / Super Voisin

If the issue continues try messaging a Customer Service Agent from a different WiFi/IP address. As mentioned before, the app is the best way to sign up and it should work for you on a different WiFi. You could also clear Cache/Cookies before trying again. It seems the issue is your father’s phone isn’t eSIM compatible, which I’m sure you’re aware of.

Mayor / Maire

@SimonHoch   "tried messaging the CS_Agent but when I try to send, it says there's "invalid HTML" and never works."   I had that happen once when I copied and pasted into a message.   If you by chance did that, I would try again but make sure to type everything in.  The private messaging usually works.

Great Neighbour / Super Voisin

We can't use the app because it doesn't recognize my dad's email as a valid email. I'm guessing it's because he hasn't activated his account yet? It's like a catch22.

Also good to know, but there doesn't seem to be a way to go back and ask for a physical sim at this point, especially with him being locked out of the website.

Mayor / Maire

HI @SimonHoch 

did you try using the app? the Subscription, while it can start with the website, will need the app to complete it.  It is best to start the activation from the app

A11 is not eSIM compatible as far as I know, so, pick Physical sim

Need Help? Let's chat.