Showing results for 
Search instead for 
Did you mean: 

New Samsung phone sim doesn't seem to work that well in it

Good Citizen / Bon Citoyen

I had an s10 plus. 2 days ago I upgraded to the 20plus. Sim works fine in the S10plus; I cannot get any calls, cannot dial out, can't even text. 

Anyone know what would cause this?


Good Citizen / Bon Citoyen

Well, that was - not good.

I did the restart with the sim in it, and still no service (at times it shows one bar, but I had my neighbour call me and no call came through, phone doesn't even ring... no texts coming through at all... ) 

I did a FACTORY reset - and just when it was finishing up, I realized that I no longer had my s10plus to transfer ALL of my files over... phone numbers are all gone... gahhhhhhhhh

And STILL - That SAME SYMBOL is there (see photo from earlier)...

I have never experienced this with Public Mobile - and I've been a customer for about 5 years... 


My new phone is a 5G model, could that have something to do with it?


Feeling EXTREMELY annoyed 

@amp247   Virgin and PM uses the same network towers , so if it works there, it should work here


Start with a Reset all network and see if it works


If still not able to connect ,  Please try to have the PM sim card inside  the phone and perform  a Factory reset  with it and see if it works



Good Citizen / Bon Citoyen


Good Citizen / Bon Citoyen

Checked, it's not blacklisted. I purchased it from Bestbuy... "open box".

I just tried a Virgin Mobile SIM and it picked it up no problem. Returned my PM SIM and it goes to "no service" symbol right away. 

The SIM worked fine in my  s10plus.. the moment I took it out of there and put it in the s20plus, it's mostly no service once or twice I heard it slamming in some texts.. but I am not getting those either. 


@amp247   does the phone connected to PM at all ?

data works?


check if the phone is blacklisted here, for peace of mind


Need Help? Let's chat.