cancel
Showing results for 
Search instead for 
Did you mean: 

MMS cannot send (MMS receive works, SMS send works)

Yggy
Great Neighbour / Super Voisin

Hello,

I am using Public Mobile with a Motorola Moto g6 phone (Android version 9, up-to-date). A few days ago MMS sending stopped working - it worked fine prior to that. I can still receive MMS messages (group chat and photos) but I cannot send. I can still send SMS messages.

Things I have checked / tried:

  • network is active
  • mobile data is turned on
  • I rebooted the phone
  • I removed the SIM card, rebooted, reinserted the SIM card and rebooted again
  • checked the APN settings, per this page - the only difference was that I had MMS port 80, not 8799. I changed the port to 8799, saved the APN settings, and rebooted the phone, but it made no difference.

Many thanks for any help or suggestions!

6 REPLIES 6


@CalvinW wrote:

Same boat as you. Nothing worked on my 2019 phone. Tried changing APN settings and contacting CS agents. Guess it's either get a new phone or switch from this lacklustre network. 


NOTHING is wrong with your phone!
I have phones from 2016 and 2019 and everything works perfectly. I JUST tested MMS sending a picture and it it took 4-5 sec to get to destination.

It could be something is screwed up with your plan. I heard that PM can reset your account and it might help.

Contact agent AGAIN. Be persistent. You are paying for the service and you expect it to be provided. And do not think that Other providers do not have issues. You will just pay more so 'live' support gets their salaries.

CalvinW
Deputy Mayor / Adjoint au Maire

Same boat as you. Nothing worked on my 2019 phone. Tried changing APN settings and contacting CS agents. Guess it's either get a new phone or switch from this lacklustre network. 

Yggy
Great Neighbour / Super Voisin

Thanks for the info, you may well be right. The announcement links to this page, with instructions for updating APN settings, which is what I previously tried and it didn't work.

That's disappointing, why would they discontinue a service that was working just fine?

Yummy
Mayor / Maire

I assume your DATA is On as that is requirement for MMS (will not use your data allotment, though).

Yggy
Great Neighbour / Super Voisin

I also checked the APN settings here ...
https://apn.how/ca/public-mobile/motorola-moto-g6

HALIMACS
Mayor / Maire

Possible you may be in this group, @Yggy - though it's a few days earlier than they planned:

https://productioncommunity.publicmobile.ca/t5/Announcements/Picture-and-Group-Messaging-End-Date-Fe...

Need Help? Let's chat.