Showing results for 
Search instead for 
Did you mean: 

Error While Subscribing

Great Neighbour / Super Voisin


I had an error code when signing up to 90day plan 150 GB Data at 5G Speed and the payment went through but the account didn't finalize.


Great Neighbour / Super Voisin

Thanks. I've tried various things, but it keeps sending the code to my inaccessible phone.

In any case, I went out and grabbed a physical sim, and provided the number to Alex as he requested. Unfortunately, it's been some time since I heard back from him, so looks like I'm without a phone probably for the evening. Just have the SOS message, and no cellular connection.

What a production this has been. Wasted pretty much the entire day for something that should ave been dead simple. And I have an IT background and five years of tech support for an ISP, too. I can't even imagine what the average non-techie Joe must feel navigating this nightmare of chatbots and flakey online self-serve tools.

@FlyOdd   Good that you're at least part way there?  If you can get the code sent by email (by hitting didn't get the code or resend the code) to log in you can fix the 2FA going to the wrong phone number yourself by updating it in the Eversafe profile.  @softech explained how in this thread 

Great Neighbour / Super Voisin

Thanks for the response. Yes, back and forth with agent Alex now. He resolved the number porting issue quickly, but we could not get the eSIM to work. Alex wanted me to make a change to my account in the app to resolve the eSIM issue, but the app kept sending the 2FA authentication code to...the phone number I can't access! (Seems like a pretty obvious problem, doesn't it PM?) So I ran out and grabbed a physical SIM. Just waiting to see if Alex can get it to work. Fingers crossed.

Mayor / Maire

@EmmieBell  You can contact customer service for help using this link to explain what  happened 

An agent will reply at the envelope icon top right, or tap your avatar for Messages if no envelope.

@FlyOdd   Usually the agents reply quite quickly so hopefully you have heard back by now.  For some reason using IMEI instead of old providers account number seems to often cause problems.  

Great Neighbour / Super Voisin

Sorry to hijack, but I have the exact same issue. Downloaded the PM app, went through the entire process, then received the same "Subscription not activated" error message from the app at the end of the process. Tried deleting and reinstalling the app, but it just opens again at the same error screen. Sent DM to cs_agent but no response as yet. I am trying to port my Rogers number over and use the eSIM in my iPhone 13 Pro max (which the initial online compatibility checker said was fine when I provided the IMEI).

My credit card sure was charged in a timely and efficient manner though! LOL...

Mayor / Maire


Are you using the PM app to activate your SIM?

Need Help? Let's chat.