Showing results for 
Search instead for 
Did you mean: 

Porting from sim card (Koodo) to sim card (Public) failed activation at step 6

Good Citizen / Bon Citoyen

Currently making a post for posterity if this gets solved.

Currently having issues with the app and activating a new plan on a sim card while porting my old number.

I've open a ticket and will try to contact support again if it gets through (long wait time) but was wondering if anyone else has any tips to make getting through this issue a bit more smooth.

As of now I have both the old sim card and the new one and I've tried to activate it by porting my old koodo number (not prepaid) over, but it had failed at step 6 and is now stuck there any time I log back in via the app.

Because the contact us hasn't work I've submitted a ticket via

Is there anything else I can do except just waiting and hope that there is a day that I can get through the customer service queue?


Good Citizen / Bon Citoyen

If anyone ends up here on checking with RCS issues.

With Samsung phone (mine is an S10)

Deleting the cache and data on the Goggle Messenger app and then re-enablinng RCS confirmed the number almost instantaneously.

I was hesitant on deleting my data initially cause I was afraid of losing my texts, but that data doesn't get deleted.

I did lose my RCS notification in the past but the messages themselves and photos/gif remained.

I also did a bunch of other stuff before deleting and I don't know if that working in tandem with the delete is what set up RCS again.

@Jameson007 PM support usually reply on the same day.  Did you check the Community inbox here:

If really no reply, please message them again

Good Citizen / Bon Citoyen

Have you heard back from support? I opened numerous tickets and still no responses. Right now I have a $44 useless SIM card I can't even use.

Good Citizen / Bon Citoyen

So submitting the ticket through

was the way to go.

I got an email and sent over the phone number and account number and (with my old sim card) confirm the port via sms and I'm now on public

Still trying to set up RCS though

Good Citizen / Bon Citoyen

I am in the same boat. I purchased a SIM from Black Friday and got stuck on step 6. I opened tickets and sent numerous requests and it has now been 3 days now and no response. Pretty much have given up on this. Just hope I don't get billed in the future for a non-activated account. Willing to eat the $45 and consider it a lesson learned to not have done my research on public mobile before switching.

Good Citizen / Bon Citoyen

Yup relogging in and playing with the sim card is the first thing I tried.

No replies yet but I'll keep a lookout through the weekday


@ShadowzXIII PM support is all online and you have done that correct thing to message support.  Support usually reply within 1 or 2 hours.  Did you check the Community inbox for their reply?  If no reply still, message them again tomorrow

Also , did you try to logout the app and relogin the app to complete the activation?? many tried and that re resolved the activation error problem 

And try to put the PM sim card and check if it works

Need Help? Let's chat.