Showing results for 
Search instead for 
Did you mean: 

Phone function not working

Great Neighbour / Super Voisin

Until a few minutes ago, my android phone didn't work.  It used to work and is now functioning properly.  I had incoming calls today from a friend and my smart phone didn't ring. Text and data are fine.  I have subscribed with "100 minutes Canada-wide Talk" and I've used only 9 minutes in the current billing cycle. I called my number from our land line half an hour ago and it didn't ring.  I checked to make sure that "do not disturb" wasn't on and to make sure the volume on the device was at max - after testing the phone with a friend it still wasn't working, so that wasn't the problem. I checked the phone history log and the calls that were made to my phone today weren't showing.  Then I restarted my phone.  I see the website look has changed since I last communicated with you, and I had to register again, but it looks like that issue is resolved.  I also just tried an outgoing call and it worked.  So I'm back in business now.  Maybe my phone just needed a reboot.  Thought I'd check just in case others have had the same problem.


Great Neighbour / Super Voisin

Thanks for the tip Kenneth.  I've done that now.

Mayor / Maire


Rebooting the phone and reseat the SIM care the 2 go to trouble shooting solutions but also refresh the browser by clicking on the circular arrow when you are on your account to get updates on your usage.

Mayor / Maire

Go into your settings, locate your Network Settings, take it off Automatic and choose Public Mobile. Then reboot. See if that resolves it. The other thing as well, confirm you have the latest firmware / software update on your phone. 

Need Help? Let's chat.