cancel
Showing results for 
Search instead for 
Did you mean: 

Activating a new SIM card keeps giving payment error

Gsimhan
Good Citizen / Bon Citoyen

This is really frustrating for me. First I tried to order a SIM card and they have charged 2 times for that but I have received only one till now.

Next I am trying to activate the SIM card as a new account and it keeps giving me an error while making payment as "Unable to process payment. Please check your details". I did verify the information and they are correct. And in fact the same credit card is being used for autopay in my another account but when I am trying to use it here it gives me error. I even tried calling my bank's customer care to check if there is any issues with my card but they mentioned everything is correct and they do not see any decline message from their end. I infact troed submitting an order while on call and they confirmed their system is approving the transaction but somehow public mobile seemsto be rejecting.

I have already sent private messages to Customer support but they are not sure how to help on this as I have tried all the suggestions from them like clearing cache, cookies, using incognito browser, use a different browser, use a different laptop etc But nothing seems to work and everywhere the same error. I have also raised a ticket now. Not sure what is happening with Public mobile. It looks like they want us to move out of public mobile. 

13 REPLIES 13

Gsimhan
Good Citizen / Bon Citoyen

I am checking up with them. But they did check at their end and mentioned the account is not yet created for the SIM card number at their end. 

Gsimhan
Good Citizen / Bon Citoyen

I am not porting any number just getting a new number


@Gsimhan wrote:

This is really frustrating for me. First I tried to order a SIM card and they have charged 2 times for that but I have received only one till now.

Next I am trying to activate the SIM card as a new account and it keeps giving me an error while making payment as "Unable to process payment. Please check your details". I did verify the information and they are correct. And in fact the same credit card is being used for autopay in my another account but when I am trying to use it here it gives me error. I even tried calling my bank's customer care to check if there is any issues with my card but they mentioned everything is correct and they do not see any decline message from their end. I infact troed submitting an order while on call and they confirmed their system is approving the transaction but somehow public mobile seemsto be rejecting.

I have already sent private messages to Customer support but they are not sure how to help on this as I have tried all the suggestions from them like clearing cache, cookies, using incognito browser, use a different browser, use a different laptop etc But nothing seems to work and everywhere the same error. I have also raised a ticket now. Not sure what is happening with Public mobile. It looks like they want us to move out of public mobile. 


First off, get the customer support agent to refund you for the SIM card that you didn't order or didn't receive (or have them send you another SIM card).


@will13am wrote:

@Gsimhan , the activation portal has always been rather finicky with credit card entry.  In the past the big issue was with how the postal code was entered, space in the middle will cause an error.  I believe that if there is multiple failures the system does a session lock that times out after about an hour.  This could be the problem here.  


Fortunately, one good thing that came out of the Selve Serve overhaul was the blocking of anyone entering a space. I have always considered is general knowledge that a space should never be inserted into a postal code when entering payment infromation.Unfrotunately, I believe that Public Mobile's own help articles mentioned something such as using a space but leaving off the last digit.  A properly designed payment system shoudln't even be looking at a space in the postal code, nor should it ever have left anyone type one in to begin with.

esjliv
Mayor / Maire

@Gsimhan , so annoying, I'd go back to the ticket you opened with the CSA agent and say help me activate this SIM card!

If you tried their suggestions, then they should step up here.

Maybe also ask them is this SIM Card already activated? Who knows maybe your attempts did do something.

@Gsimhan    Purchase a voucher from SDM, London Drugs, 7/11, Shell or even recharge.com and then submit a ticket and ask customer support to add the voucher funds to activate your account.  It's been confirmed by oracles that PM support will be able to add the voucher for activation even though that option is not available during activation.

 

Make sure you are clearing cache/cookies and using incognito mode too.

 

@Gsimhan did you get the error at payment or error with phone number porting?

Gsimhan
Good Citizen / Bon Citoyen

I started this yesterday. I followed all and still had issues. Then I tried again today but nothing changed. Same error

dr-et
Great Citizen / Super Citoyen

Gs try again from the beginning on a new window you might not get the same number but it worked for me

started mine at 10 and just finished now  good luck

dr-et
Great Citizen / Super Citoyen

just finished activating mine same frustrations  .the activation portal is not finicky its a disaster imagine amazon having customers spending 8 hours trying to pay for a product.

to Gs erase everything and start from the begining that might work for you

please log in again on pm to restart the process  dont bother with different cards you will get same results

Yummy
Mayor / Maire

It looks like you tried everything and have followed every advice. Even talked to agent...

Maybe you should try activating SIM tomorrow after 24 hours from first attempt.

Really frustrating if even agent cannot help you out.

dust2dust
Mayor / Maire

It often does seem like they just want to wrap it all up and forget about it doesn't it.

Did the agent say to wait an hour or so? Did they notice any fraud alert flags? Would they be able to watch at the moment you click go?

will13am
Oracle
Oracle

@Gsimhan , the activation portal has always been rather finicky with credit card entry.  In the past the big issue was with how the postal code was entered, space in the middle will cause an error.  I believe that if there is multiple failures the system does a session lock that times out after about an hour.  This could be the problem here.