cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Great Neighbour / Super Voisin

Autopay Reward Not Applied

Hello,

 

I have been a customer since June 2018 and each month I have been paying the same amount ($120 plus tax) with my auto pay but when I review the account it shows that I am eligible for auto-pay reward of $6 plus a loyalty-reward of $3. What do I need to do so I only pay $111 plus tax given I am receiving a total of $9 in rewards? Can you please adjust my payment so it only takes the balance after the rewards are applied? Also, how do I get all the rewards that I didn't receive since June 2018? 

 

Thanks,

J

Mayor / Maire

Re: Autopay Reward Not Applied

@JoeSathLog into your selfserve and go to Payment history you should see line items of AutoPay bonus applied during the renewal cycle. Paste some screenshots up here so we can help you decipher what is going on.

Mayor / Maire

Re: Autopay Reward Not Applied


@JoeSath wrote:

Hello,

 

I have been a customer since June 2018 and each month I have been paying the same amount ($120 plus tax) with my auto pay but when I review the account it shows that I am eligible for auto-pay reward of $6 plus a loyalty-reward of $3. What do I need to do so I only pay $111 plus tax given I am receiving a total of $9 in rewards? Can you please adjust my payment so it only takes the balance after the rewards are applied? Also, how do I get all the rewards that I didn't receive since June 2018? 

 

Thanks,

J


@JoeSath Definitely a problem with your account. The best thing to do is to bring this issue to the PM moderator team. They will review your account and fix the issue and also apply the missing credits.

 

To contact Public Mobile click here. The link  sends you to the private message function and adds the moderator team as recipient for a private message. You just have to enter a title and text in the body of the message describing the problem and post. The message will be received by the moderator team and they will respond to it. You will receive the response in your private message inbox.

Moderators are available: M-F from 8 AM to midnight Eastern time and S-S from 8 AM to 10 PM Eastern time.

Note: Moderator Hours are subject to change, but you can always find the current times here

Please note that account verification may be required when contacting the Moderator Team 

 

Great Neighbour / Super Voisin

Re: Autopay Reward Not Applied

Thanks geopublic. I figured out the private message after I posted it here. Now not sure how to remove this message from here? 

Mayor / Maire

Re: Autopay Reward Not Applied


@JoeSath wrote:

Thanks geopublic. I figured out the private message after I posted it here. Now not sure how to remove this message from here? 


@JoeSath  Just click on one of the accept as solution buttons an the post will close.

Re: Autopay Reward Not Applied


@JoeSath wrote:

Thanks geopublic. I figured out the private message after I posted it here. Now not sure how to remove this message from here? 


This site is about asking questions, so I don't anyone will have a problem with your message post.  If you wish, you can edit your message.

Re: Autopay Reward Not Applied


@geopublic wrote:

@JoeSath wrote:

Thanks geopublic. I figured out the private message after I posted it here. Now not sure how to remove this message from here? 


@JoeSath  Just click on one of the accept as solution buttons an the post will close.


There is no way for any member to lock or close a thread.  Marking a solution is way to show thanks to a helpful member but the thread remains open.

Re: Autopay Reward Not Applied


@JoeSath wrote:

Hello,

 

I have been a customer since June 2018 and each month I have been paying the same amount ($120 plus tax) with my auto pay but when I review the account it shows that I am eligible for auto-pay reward of $6 plus a loyalty-reward of $3. What do I need to do so I only pay $111 plus tax given I am receiving a total of $9 in rewards? Can you please adjust my payment so it only takes the balance after the rewards are applied? Also, how do I get all the rewards that I didn't receive since June 2018? 

 

Thanks,

J


@JoeSath, I think your AutoPay just needs to be reset if it’s still listed as Active.  A few months ago, certain subscribers noticed similar things happening.

 

Go into selfserve, turn off AutoPay, then turn it back on.  You can also do this by calling 611 and using the IVR system to do the same thing.