Showing results for 
Search instead for 
Did you mean: 

Problems upgrading plan

Great Neighbour / Super Voisin

I'm trying to upgrade my plan, but when I click on the plan tab, it either asks me to log out and log in again, or does bring me to the page, but there is nothing there. What should I do?


Good Citizen / Bon Citoyen

Good to hear that it worked, if you have similar issues try another browser like Firefox or Chrome 

Great Neighbour / Super Voisin

Thanks, it worked!

Mayor / Maire

Funny I switched my plan earlier and had the same thing even in incognito mode. I had to just try later and it worked. This is very common

Mayor / Maire

@Syd22 It sounds like your plan wasn't properly set up to begin with. Use the one time payment option to deposit the amount of money for the switch and contact the moderators and get them to go to it for you. Click on the green questionmark in the white circle at the bottom right of your screen.  This connects to the autobot Simon.  Type moderator and follow the prompts to get to one (CLICK on "Account specific question" and  "No I want a human" and "Submit a ticket Click me!")
Once connected, you will be asked to log in again with your community user name and password.  Please do, this allows you to continue and send your message.
Check your private message sent box (click on the envelope top right of your screen) to make sure the message was sent. Also keep an eye on the envelope, the mods answer will show up there. Once it does, you will be asked to verify your self service account, with your password and login. Doing so allows the process to continue.
If you need to, you can also enable email notification to receive a private message notification sent to your email. Go to your community account > my settings > PREFERENCES > Private Messenger > enable "Receive email notifications for new private messages" > Save

Welcome to the community.  Stay safe. 

Mayor / Maire

@Syd22 Hello Try wiping out your cache turn off /reboot computer try again in incognito mode in Chrome good luck

Mayor / Maire

@Syd22 open your browser in incognito/private mode and try again. you can also clear your broswer history/cache, but there is no point if you use the above mentioned mode.