cancel
Showing results for 
Search instead for 
Did you mean: 

Phone plan

Nell2499
Great Neighbour / Super Voisin

I was on the $15/mo 100 minute plan and on September 20th I topped up my account and switched to the $30 3gb, unlimited calling plan. When I log in, it still shows my old plan and that I am about to go over my minutes but when I go to my payment history, I can clearly see that I changed my plan. Help!

9 REPLIES 9


@Alexandf wrote:

@Nell2499 

try reboot phone


@Alexandf are you presuming they are on mobile and restarting the phone will help My Account refresh itself?

What if OP is on desktop? How will restarting the phone update the plan details?

Moved:

Reomoved a post that was unrelated to the topic: reoboting the phone cannot change the plan that the customer is on

@Nell2499 

 

There is no $30 plan. Are you asking about the $35/3GB plan?

@Alexandf- Where did it say they changed the plan speed?

Moved:

Irrelevant message removed. There isn't any 48 wait for a speed change when the plans with 250MB and 3GB are both 3G plans.

dust2dust
Mayor / Maire

@Yummy- Because they don't want to expend the resources to fix anything. They blew a bit of a wad making the new system, seemingly did little to no testing, what might have been tested didn't seem to be fixed, rolled it out incomplete and bug-ridden anyway....here we are. I'll allow that there are a couple nice features. But that hardly balances against the awfulness.

It's embarrassingly, ridiculously, appallingly bad. I sure would have liked to have heard if any heads rolled. Because whoever put this together needs to be gone and never to be heard from anywhere else.

Yummy
Mayor / Maire

REALLY frustrating with this 'caching issue'. Why nobody cares????

Try using different browser. Try Incognito mode. Clear browser’s cache. Try forced refresh.

dust2dust
Mayor / Maire

Click the little spinner refresh icons lower down or use private mode. It should update.

will13am
Oracle
Oracle

@Nell2499 , you are probably seeing a cached page of your self serve account.  Try using incognito mode on your broswer.