cancel
Showing results for 
Search instead for 
Did you mean: 

Phone not working

SCIWC
Good Citizen / Bon Citoyen

My payment was automatically taken on May 10 and I haven’t had any service (phone or text) since May 11.  Pubic Mobile doesn’t even show up in my carrier options on my iPhone anymore (iSO 15.4.1).  I’ve checked for updates (my husband’s Public Mobile service on his  iPhone is working), rebooted, removed the SIM and nothing’s working. I’m not restoring my phone to factory settings!

I’ve had this problem several times since September where they take my payment automatically and then suspend my service for a day. FRUSTRATING but this time it’s 4 days. 
To make it worse, you can’t call for help and their service isn’t open for chat till 10 am AST.  
I changed my backing from visa debt to Mastercard and maybe that’s the issue. I don’t know but I’m beyond frustrated. 

1 ACCEPTED SOLUTION

Accepted Solutions

@SCIWC 

To Reset of your device's Network Settings see below.

This also resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you've used before.

Iphone:

To Reset Network Settings, begin by opening the Settings app. Next, tap General -> Transfer or Reset iPhone -> Reset -> Reset Network Settings. and enter your passcode.

Your iPhone will reset network settings and restart itself.

 

View solution in original post

21 REPLIES 21

darlicious
Mayor / Maire

@SCIWC 

You have logged into your account and confirmed it's status? It's suspended? Is your payment in your available funds? Or active and you have no working services? Which plan do you have?

 

 

 

 

To contact customer support : Submit a support ticket via SIMon the chat bot Click here 

 

Or if you cannot submit a ticket via SIMon then Click here   ....for additional member supplied info.

DaisyR
Great Neighbour / Super Voisin

Go into your account and make sure auto roll is activated.

esjliv
Mayor / Maire

@SCIWC - 

Perhaps it is connected to the change of payment card if that is when this started. But depending on what your account status says when you have no services that could tell you something...If Active status and service kicks in on it's own that is weird.

 

This has been going on since September during / at renewal time? And does your account say registered for Dynamic Autopay?

Because of this happening for months, I would suggest to contact CSA and tell them the issues you have been having.

 

Public Mobile Representatives customer support agents (CSA) can be contacted, by either two methods, found here:

https://www.publicmobile.ca/en/on/get-help/articles/contact-an-agent

 

HALIMACS
Mayor / Maire

@SCIWC 

 

So to be certain, you are trying to send text messages and make phone calls and you are unable to?

 

Or are you just seeing this messaging in your self serve on the eve of renewal and thinking that they have suspended your account?

 

This message always appears on the eve of renewal and it's just Public Mobile's way of renewing accounts:

 

HALIMACS_0-1652530178884.png

 

 

SCIWC
Good Citizen / Bon Citoyen

I checked and the money was definitely taken out of my bank account on May 10. In my PM account, it shows as active and I even received a text thanking me for my payment. Public Mobile is not listed as one of my Service Provider options in my phone settings, I can’t make or receive calls or texts. 

SCIWC
Good Citizen / Bon Citoyen

I was using a credit card up until September and never had a problem. I switched to a debit visa and 3 months (since Sept) it said I didn’t pay, cut off my service and I had to pay manually. The other months, the auto pay took the payment and no issues.  Then this month, it took my payment, shows my account as active but I have no service. 

SCIWC
Good Citizen / Bon Citoyen

Checked and it is. 

SCIWC
Good Citizen / Bon Citoyen

It’s active and no funds available and my next payment is June 9. 


@SCIWC wrote:

Public Mobile is not listed as one of my Service Provider options in my phone settings, I can’t make or receive calls or texts. 


@SCIWC   That could mean it  might be either a device issue or SIM card

 

Did you try to put your SIM in another phone and see if it works?  If it works, then it is the device.  

 

Also, what is the status showing on the phone?  Any error message like "SIM not provisioned", "No network", "No SIM"?