Showing results for 
Search instead for 
Did you mean: 

Phone not allowed No network

Good Citizen / Bon Citoyen

I ported my number over to p.m. Two days now my phone number is not working There is no network The IMEI is unable to register on PM network. It did register initially when I ported the number over, but they were some residential issues with the EM the menu options in my iOS under settings. Cellular were not what they were supposed to be.

I went to a Telus store and bought a physical Sim and as per their advice, I inserted the physical Sim and now the phone is not able to connect to network at all. 

There’s no problem with the phone when I insert a different Sim card it registers on all other networks no problem

I have left four tickets. No one has got back to me.  I left other messages in the community forum with screenshots better explaining the situation, and these get marked as spam and never appear. 

I’ve gone through all the usual troubleshooting steps, power, cycle, phone, network settings reset everything short off a full hard reset on my phone 

can anyone help please? I’m without a phone and unreachable. This is a particularly bad time for me to be so. 



Good Citizen / Bon Citoyen

Thank you for that. Yes I have included all relevant details in my tickets name phone number account number; IMEI  number, sim number .. 

every possible detail they could need.. 

I just need someone to get back to me now

Model Citizen / Citoyen Modèle

Just so you know when they respond they will ask for your name number and email to verify that its you. Add this to your first ticket as you won't have to wait for a second response Just to answer.

Good Citizen / Bon Citoyen

Thank you Rastin

Yes, I have tried all these things No, my old Sim is no longer active 

Like I said the number ported over correctly it worked OK for a day It’s just that network bars wouldn’t show up top right hand side where they normally reside and cellular menu. Options were not what they usually show in iOS. 

To fix this issue i went to a Telus store got a physical SIM  once I inserted the physical Sim I got completely cut off from the PM network

Now it only shows SOS, where normally cellular network data bars show 

This has been the last two days And I am stuck because of this , unfortunately, had a very bad time where I cannot be unreachable. 

I’ve scoured every thread , every bit of information on the Internet about this To me it seems my IMEI is not able to register on the PM network Because of issues are their end It might just take five minutes to fix, but somebody has to get back to me. 

Good Citizen / Bon Citoyen

Thanks for replying

I’m sorry I don’t quite understand, How am I making it more complicated than it is?

I have tried all the steps. Yes, my subscription is active.

this is so debilitating my phone is not working people from around the world trying to reach me. I’m stuck at home because this is the only place where I have Wi-Fi. 

And no one is responding From Public Mobile 

Model Citizen / Citoyen Modèle

Unfortunately it sounds like you have done about all you can do. How long have you been waiting for a reply? I have only ever put in one ticket myself took 24 hours for first response and 36 for there second.

Did you try your sim in a different phone? I know you put different sim in yours.

Also check your old sim and make sure it's not still active.

Mayor / Maire


An agent will reply by tapping on your avatar then Messages.

At this point, you are making it more complicated than it is. It looks like you tried everything rightly.
Did you try login to your account and see if your subscription is active?

If you can’t login…just wait for an agent to help.

Need Help? Let's chat.